cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
Highlighted
Level 2
30 18 0 0
Message 1 of 4
113
Flag Post

HP Envy x360 13.3 inch CPU problem

HP Recommended
Envy x360
Microsoft Windows 10 (64-bit)

Hi all,

At the moment, i’m experiencing an issue with my HP Envy X360 where the CPU speed is sitting at around 0.40ghz. This has happened since I changed the M2 SSD and installed a clean version of windows onto it. However I suspected that the new M2 SSD wasn’t compatible so I put the original M2 SSD back into the machine and performed a restore using the factory restore image on the SSD that it shipped with. After performing a restore I noticed that the battery was no longer charging but was recognised as being plugged in and the CPU speed is limited to 0.40ghz, anyone got any ideas how to fix?

I read a previous post on here about updating the firmware from Device Manager, this seems to have cured the issue of the battery charging as it now shows it being 100% fully charged whereas before it said it was plugged in but not charging and the battery was only at 27%. I am however still experiencing the lack of CPU power.

If anyone could help me, that would be greatly appreciated.

3 REPLIES 3
Highlighted
HP Support Agent
HP Support Agent
27,511 27,465 2,272 3,463
Message 2 of 4
Flag Post
HP Recommended

@GarethS1994 Your suspicion on the SSD not being compatible, was that a hunch or did you go through the maintenance and service guide of your HP device? I respect both, but HP prefers you check the guide before making any hardware changes, to be on a safer side, to obtain the same for you, here's what I'll need:

 

Note: Please ensure the complete product name/number for a quicker response from the community, as we need to know what we are dealing with to provide an accurate solution: 

Click here for steps on finding the information we need!

Remember: Do not share any of your personal information such as serial, phone number, email ID, etc.

 

Also, how was the OS reinstalled on the SSD, did you make use of the HP Recovery partition (F11) or did you use the HP recovery media? 
If you don't have an HP Recovery media and have attempted reset using the windows troubleshooter or a retail copy of windows, you'll need to order a recovery media: Click here for steps.

Or you may also attempt to download the same using the steps on this link: click here

 

For details on how to perform a successful reset: click here

As for the battery issue: click here to calibrate and test the same, get back to us with the results.

 

P.S: Welcome to HP Community 😉

 

Keep me posted, as I (Or a trusted colleague) shall follow-up on this case to ensure the concern has been addressed, 

And your device is up and running again, only in case you don't get back to us, first! 

That said, If the information I've provided was helpful, give us some reinforcement by clicking the solution and kudos buttons, 

That'll help us, and others see that we've got the answers!

Good Luck.

Riddle_Decipher
I am an HP Employee

0 Kudos
Highlighted
Author
Level 2
30 18 0 0
Message 3 of 4
Flag Post
HP Recommended

Hi Richie,

 

Thanks for the reply. I have tried all of the above that you’ve mentioned. The battery test came back as working normally. What’s interesting is that if I go into the BIOS and load the system defaults by pressing F9 and selecting yes and then save and reboot, the CPU works fine, however when I reboot the machine again, it goes back to 0.40ghz and is really laggy again.

 

If you could point me in the right direction on how to fix the issue, then that would be great.

0 Kudos
Highlighted
HP Support Agent
HP Support Agent
27,511 27,465 2,272 3,463
Message 4 of 4
Flag Post
HP Recommended

@GarethS1994 So, in other words, you've made use of the HP Recovery media to install the OS and yet have these issues, and you've confirmed the SSD is compatible with your product using the maintenance guide? Could you share your product information as requested, earlier?

 

Meanwhile, please consider using the "Power" settings to step-down from "maximum-performance" to "balanced",

And check if that helps with the lag.

Keep me posted

Riddle_Decipher
I am an HP Employee

0 Kudos
Be alert for scammers posting fake support phone numbers on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation