cancel
Showing results for 
Search instead for 
Did you mean: 
Anon16
Level 3
34 31 1 9
Message 31 of 47
241
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

I've deleted this post's original content for now.

I want to be sure all details are accurate; I'm not sure that one of the details I'd posted was accurate, so I'm removing for now.

 

(Even though my overall sentiment remains! … this isn't exactly being dealt with quickly by "premium" support)

 

(Can't see how to actually delete, only edit)

Reply
0 Kudos
Banjomx
Level 2
15 15 0 4
Message 32 of 47
226
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

I have updated to F32a in the meantime, full of hopes....and now....nothing!! It's the same as F31, but now i have sudden shutdowns 1/3 times a day too. It seems the pc goes in protection mode due to high temperatures. What a mess... HP is really trying it's best to push me away from them. I'm also starting to experience random BSOD once in a while, leading to lost work. While i cannot exclude a software issue, i suppose the constant high temperatures is starting to leave a mark on the hardware.

 

I wonder if this problem will ever be solved...my patience is running out

Reply
0 Kudos
Anon16
Level 3
34 31 1 9
Message 33 of 47
199
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

Finally, months later an updated BIOS arrives F.40 ... hurrah...! 

 

  • Only 3 full months for Premium Support to get to this stage...

And guess what....

 

  • NOPE it doesn't fix the problem..

I bought a PC with a 4GHz peak, 2.2GHz base frequency CPU that is running at times (i.e. time when performance is actually needed) still down to 0.8GHz.

 

Seriously ... I wasted my money on this PC... enough's enough - it is not the high performance PC that I paid for. I really have had enough of this now. 

 

This is using HP's own diagnostic stress test that is supposed to run the CPU cores all at 100%....

 

BiosF40StillNotFixed.png

 

It's taken HP Premium Support WEEKS to produce this update - now 3 months since first reporting the problem to them.

 

For them to release this when it doesn't fix the problem is shocking.

 

Premium support told me this version of BIOS was created on 10th Dec but I had to wait for it to be tested properly before release to confirm that it fixes my problem.

 

Well, HP Premium Support it doesn't. 

 

What was your supposed 'testing' doing? I now struggle to believe that any testing of this BIOS version was being done in relation to fixing my problem. I'm now firmly of the view that Premium Support were probably just hoping, and that this new version was probably being released for someone else's issues, and premium support just saw it as a way to kick the can down the road even further in relation to the problem I'm encountering.

 

I really do now feel like I've been conned.

 

This is shocking - I have a supposed $2000 HP PC that is performing slower than a $500 PC ... well below it's advertised speed.

 

If I'd bought this from a market stall I'd be contacting trading standards reporting them as conmen for selling fraudulent goods - in this case selling a premium PC with an advertised base speed of 2.2GHz (peak 4GHz), only to find when I get home it actually runs down at 0.8GHz (yes, that's zero-point-eight) when actually used in a way that attempts to make use of the supposed high performance.

 

But because this is HP, a well known international company, and they supposedly are providing "Premium" support, well, that somehow makes me think I'm dealing with a 'reputable' company.

 

But now how can I continue to believe that? - this PC is now 6 months old, HP premium support are dragging their heels, don't seem to accept / understand the problem and are repeatedly failing to provide any kind of actual fix.

 

So the reality is, that I have a PC that is not performing in the manner it was sold. 

 

At what stage after getting your Ferrari home, and finding it limits itself to 40mph, do you accept you've been conned?

 

I've now been driving this supposed Ferrari for 6 months, limited to well below the speed I was promised when I bought it. 

 

I've been conned, haven't I?

Banjomx
Level 2
15 15 0 4
Message 34 of 47
178
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

I understand you man. I feel fooled by HP too. PC has been ruined by a ninja pushed, untested firmware update, they locked out rollback (intentionally or not, it's their fault anyway) and talking to their "support" (i doubt it's the right word) is like talking with my chair, useless: no meaningfull response, no proper problem escalation to related development team and noone in their company who can actually take a pc and test the problem internally. Honestly, it's not acceptable, especially after moths of patience.

Now, beside the gimped performance, it's the constant high temperatures the pc is keeping inside the whole day that worries me more. I ended up buying an ACER notebook and moved my work on this new PC. My spectre is 7 months old and is now performing worse than my first alienware with 3630qm, all while burning alive.

Now, with the new one, i can control the fans, i have 4-5x the performance of the spectre, no throttling and temps do not even reach 70°C in peak computing times. I now use spectre for casual internet browsing, mails and little more. Yes, like a tablet. The most expensive tablet i bought in my whole life.

 

Thanks HP, you gained a loyal customer.

 

Edit: corrected the tag i entered unintentionally

Reply
0 Kudos
Anon16
Level 3
34 31 1 9
Message 35 of 47
136
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

Just to add..  after installing F40 and finding it doesn't solve the problem (as per my previous message)...

 

... bear in mind, that's after waiting for over 1 month all the while being given the impression by HP Premium Support that this BIOS update was being developed specifically to resolve this issue....

 

Guess what...  I've just noticed the release notes ....

 

Fix and enhancements:

- Provides support for additional notebook models.
- Provides the updated Intel CPU microcode to improve system stability and security.
- Provides improved security of UEFI code and variables. NOTE: HP strongly recommends transitioning promptly to this updated BIOS version.

 

 

Nothing at all there related to CPU performance / frequency problems.

 

Contrary to what I was being told, that BIOS F40 isn't attempting to address the problem I'm encountering, at all!!

 

HP Premium Support are just kicking the can down the road and hoping, aren't they?

 

I'm being taken for a ride by HP Premium Support, aren't I?

 

--

 

I would also add, that the problem seems to be getting more inconsistent. Sometimes (this morning) killing the CPU speed when just watching a video (making the video unwatchable), at other times killing it when under high load when max performance is needed!!,..  but then 5 minute later, still doing exactly the same high demand tasks, it's then able to sustain 2,2Ghz minimum.

 

I'm now leaning fairly strongly towards the view that this is probably a genuine hardware problem - albeit likely intermittent. (Perhaps a loose or poor connection on a sensor related to BIOS monitoring, or perhaps a fan has an intermitted fault or poor or inconsistent performance; though this latter (fan issue) wouldn't explain why the CPU speed drops when the thermals don't seem a problem)

 

Due to the length of time this is taking to (not) resolve, and the poor response from Premium Support, it's now time I insist on a replacement unit.

 

I've had enough of this now. My patience has expired.

 

I paid for a high performance PC, and I still don't have that - 6+ months after purchase.

 

Enough's enough!

 

We'll see how premium support respond - prior to christmas one support engineer pro-actively volunteered the information that my case looks like it's been the longest case they've had open.

 

So I really hope that they understand the need to get this resolved quickly now, and stop kicking the can down the road. 

 

With no definite diagnosis of where the fault lies, and no success so far in any fixes (and clearly being misled in relation to BIOS F40), it's time for them to bite the bullet and just swap this PC for a new unit. 

 

Let's see how they respond...

Banjomx
Level 2
15 15 0 4
Message 36 of 47
114
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

Hi Anon, i would not consider unit swap in your case, as i do not consider it a valid solution even in my case.

Keep in mind those factors:

- The unit may be repaired, probably leading to a motherboard swap. It may end with the same BIOS version. In any case, i've always had bad experiences: usually they fix one problem and create another 2. I've never experienced a good repair, instead i received scratched, even non working units sometimes (with an ASUS notebook with a faulty GPU, the LCD was broken during repair and noone tested even the power on). Based on HP support experience, i have no trust in them.

- You may get a replacement unit. It will probably be a refurbished one. I have seen 3 devices of this model and there is a HUGE difference between them. Quality control seems inexistent to me. With refurbished units, it will be even worse. If u have the luck of having a good device, i suggest you keep it.

- In my case, the problem is purely BIOS related: no hardware fault. You can check by running any game on the device. If you use the dedicated GPU (i tested with witcher 3 on BIOS F31a), the fans will both run. If the unit worked well before the BIOS update, i think you are in the same boat.

- Even if you get the problem solved (aka an unit with a previous BIOS version), you are at risk of getting it updated again, as i got the BIOS update within windows updates; no confirmation was required. Leave the pc doing AFK updates once, and you may find it updated to last BIOS revision.

 

For the above reasons, while it is possible that the constant high temperatures will slowly wear out the hardware (my unit is degrading as well), i do not consider the repair/replacement.

The real solution is having one of their support team taking a **bleep** unit in hand and testing with latest firmware this case scenario. If problem is confirmed, then escalate it to BIOS development team for a fix, otherwise shipping back the unit becomes an option, as it may be a defective unit.

Here in EU, i requested the test in all the way i could: nothing, noone could do this simple test. If you have better luck or decide to swap the unit, please let me know as every bit of information is more than welcome.

Reply
0 Kudos
Anon16
Level 3
34 31 1 9
Message 37 of 47
106
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

Well, I spoke to them yesterday, and they are saying it will need to be a repair - they won't do replacement.

 

I'm not completely happy about that, and was very tempted to stand my ground and demand a replacement (with the threat of invoking the consumer rights act - they've already had reasonable time to fix this issue now), but the risk with a swap is that I might not get exactly the same model back (which has just happened to me with a satnav that went faulty under guarantee). At least with a repair, that shouldn't be a risk.

 

And the other risk with replacement, like you mention, is that they will likely replace with a reconditioned unit, which chances are won't be in the same cosmetic condition as my current unit, which I've really looked after, so there isn't currently a scratch on it - it's still absolutely as new condition.

 

>> " It may end with the same BIOS version."

 

The symptoms I'm seeing now suggest hardware issue - the problem is now showing up intermittently with the keyboard positioned forwards - previously it was only when it was pushed back. This leads me now to suspect a faulty / misconfigured sensor(s).

 

So if a repaired unit is then able to operate properly with the existing BIOS version, I'm fine with that. I just want a PC that provides the performance that I paid for! I don't care which version of BIOS is on it, as long as it works correctly with the hardware.

 

However, it does bug me - and I've really stressed this concern to the HP premium support people - they haven't actually yet had any diagnostics positively indicate any fault.

 

So how are the repair centre going to determine what should be fixed?

The HP CPU stress tests happily run at 0.79GHz and proudly proclaim "Success"!

Which is plain nonsense on a CPU with a base frequency of 2.2Ghz!

 

So my biggest concern is that I'm going to ship it off, the repair centre will put on their standard diagnostics, and that will just come back "no fault found" and they'll just ship the unit straight back still with exactly the same problem.

 

It also really bugs me that at no point, has any HP Premium Support person ever attempted to do any diagnostics of the sensors and fans. None of them have asked the question - "what information is the BIOS seeing that might be making it behave the way it's behaving, perhaps it's this information that is faulty - garbage in, garbage out"

 

 

>> " If u have the luck of having a good device, i suggest you keep it."

 

Believe me, if I ever have such luck, I will.... but right now, the unit I have isn't a good unit.

:^(

 

>> "You may get a replacement unit. It will probably be a refurbished one. I have seen 3 devices of this model and there is a HUGE difference between them"

 

That's a risk, but the unit I currently have is not fit for purpose -  it's not a high performance computer. It isn't able to reliably sustain it's advertised base CPU speed under load.

 

 

>> "The real solution is having one of their support team taking a **bleep** unit in hand and testing with latest firmware this case scenario. If problem is confirmed, then escalate it to BIOS development team for a fix"

 

Tell me about it!

 

For the past two months, I've been spun a yarn from the HP premium support that second (and even third!) level support have been trying to reproduce the problem so that a BIOS fix can be issued. 

 

I was led to believe that BIOS F40 was supposed to be the result of this.

 

In reality, BIOS F40 looks nothing of the sort - it's release notes make no mention at all of any related fix!

 

And at no point have HP Premium Support ever confirmed that they've managed to reproduce the problem themselves.

 

Now I fully admit, I've no trust at all left in them that gives me any confidence that they have ever tried to reproduce the problem themselves. I now strongly suspect they've been lying all along and haven't actually tried anything at all at their end. But I've no way of proving that.

 

But even if they have tried, at no point have they said "aha! success - we've reproduced it"

 

I've no way of proving whether or not they have actually made any attempt at all to reproduce it.

 

But they say they have, and yet they haven't confirmed they have been able to reproduce it, and the (supposed) fixed BIOS F40 doesn't fix it at all.

 

Taking what they've said at face value (I've no other option), it appears that my unit alone is suffering these problems, they can't reproduce it on their units, and added to that I'm now finding the problem intermittent...

 

… I now have to work on the basis that it looks like a hardware problem.

 

I've no other choice. 

 

They've had 3 months, getting on for 4 months now, and there's been no success. 

 

My patience has run out.

 

I'm not prepared to sit here with the unit underperforming, not being able to properly do the things that need the high performance that I paid extra for, while letting HP Premium Support just fob me off and kick the can further down the road.

 

>> "Here in EU, i requested the test in all the way i could: nothing, noone could do this simple test."

 

I'm in the EU also (sadly only for now, UK), but here in lies the problem....

 

Sure, there are reasonably strong consumer protections... but if the company isn't playing ball, the only way to enforce them is through the courts.

 

The price that I paid for this computer, I'm certainly not going to rule that option out!
I am starting to mull over at what point I send a "Letter before claim", which is the first step in the UK towards starting the legal process.

 

Though, because I do really want the computer working, I want to give HP every reasonable opportunity to fix this amicably. So if it does get to the "letter before claim" stage, it will be because I have reached the point that I feel HP are never going to solve the problem, so by that stage it will be a claim for a refund.

 

I'm also not going to rule out making more of a public fuss than just posting on this forum.

 

But at the end of the day, I did - and still do - want the PC that I paid for.

 

So I'm trying to give HP every opportunity to address the problem amicably. I'm certain now that the time I've given them to fix this (nearly 4 months now), is way beyond any reasonable time that the consumer rights act in the UK would require me to give them before taking further action.

 

But something has to change now. I'm not spending the next 2 to 3 months kicking the can even further down the road.

 

So it's now due to go off for repair on Monday.

 

Frustratingly it's going to be away for around 8 working days - but I don't really have any choice.

 

(With hindsight, I think maybe fate was trying to tell me something, giving me a  big bright sign, when the HP store unilaterally cancelled my first order for this computer without any justifiable reason - after payment had already been verified / confirmed)

Reply
0 Kudos
Banjomx
Level 2
15 15 0 4
Message 38 of 47
96
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

I understand your point. Please let me know if the repaired unit will solve the problem and if the fan(s) will start on high CPU load; for me even stress tests don't make them running. If you solve the problem, then i may consider it too.

 

Anyway, you are not the only one (just my case) and i suspect this problem is not being noticed my most users: average people don't look into hardware values or use light apps/casual browsing. They will never notice this problem even when present.

 

The support team, if they really made some tests, should have confirmed if the fans was spinning at least setting them on "Always On" in BIOS. It's not working and it clearly indicates something isn't going as expected. This test can be made in under a minute. I doubt they made even a single test.

 

Good luck man, keep me up to date!!

Reply
0 Kudos
Anon16
Level 3
34 31 1 9
Message 39 of 47
50
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

Just a quick update...  I've been typing a lengthy email to HP premium support, so I'm not going to spend long on this message now - it's late and I'm tired, and have largely had enough of this issue now...

 

Summary...

 

Unit arrived back on Saturday.

I ran some tests over the remainder of the weekend.

 

Long story short...

 

  • 'They' replaced the main board, cpu fan and vga fan.
    (Thankfully 'they' put it back together well - credit to Flextronics who this repair went to for that - my previous experience of repairs with other companies is that things never quite get reassembled correctly, but all credit to Flextronics - they put this unit back together properly as far as I can tell, and no scratches either)
  • My very first test seemed promising. It actually seemed to be working fine until I had to reboot. On starting up after reboot... WHAM ... the CPU was back down at 1.1GHz even under load.
  • Disheartened, I left the PC idle for 30 minutes and went to do other things.
  • Came back, sparked up a stress test on the CPU, and amazingly it then sustained 3.6GHz, @ 100% CPU utilisation for over 1 hour, in the configuration with the built in keyboard pushed back.

    So it definitely can work in this configuration if it wants to!!
    It seemed very stable and very happy.
    I saw little point running the test any longer beyond 1 hour...


    If it could just run like this reliably, in this very same configuration  - right from startup  (without having to wait on idle for any period) - every time I came to use it, I would be VERY, VERY, VERY HAPPY with this computer!

    It certainly proved on Sunday that it is (physically) able to do it!!!

    (And I've never known it do this before the repair - except perhaps BIOS F28 way back in June - so maybe the repair Flextronics did, has helped a little(?))

 

I managed to repeat this 2 or 3 times - after a reboot, it would initially be terrible - at 1.1GHz under load - but then leave it for 20 to 30 minutes and then it would sustain a 100% load at 3.6GHz then seemingly indefinitely, making good (balanced) use of the fans to keep it stable during the whole time.

 

So to repeat - the unit is certainly capable (thermally) of sustaining good performance, with the built in keyboard pushed back.

 

(Caveat - I didn't try anything on the nVidia 1050 GPU during these tests; I would hope the CPU would still maintain 2.2GHz if the GPU is under load, but I didn't test it, and now (see below) I can't get back the performance anyway so can't try it)

 

Though obviously.... it is not acceptable to have to wait 20 to 30 minutes in idle in order to let it get to this state....!!!!

 

And sadly, tonight when I've tried to repllicate this ....

 

COMPLETE FAILURE to REPLICATE

 

Every attempt this evening to try and  'latch' it into good performance by initially leaving it idle, has FAILED.

 

This evening, instead of switching the fans on (when put under load after a period idle) - in the way that it happily did on Sunday - this evening it instead resorted to crippling the CPU performance instead.

 

More bizarrely, after I saw the CPU performance drop, I gave up all hope, just stopped the stress test and left it idle...

 

... then 2 minutes later, guess what.... it decides to turn the fans on.
With the CPU utilisation at ZERO where it had then been for nearly 2 minutes.

 

Absolutely stupid!! Cripple the CPU performance first, then put the fan on later when the CPU is no longer under any load?! Words fail me!

 

There's just no consistency in how this unit is behaving.

 

  • I've now seen it behave brilliantly for 1hour at high performance...
  • ... and then at a different time but in exactly the same configuration and situation, it instead leaves the fans off and instead cripples the CPU performance when it's under load.

 

Anyway, enough's enough.

 

I genuinely hope that HP will be reasonable about this - I've lost any hope that this can now be resolved as a fix or repair on this unit - the support case has now been open for 4 months and it feels no nearer to resolution.

 

This isn't the PC that I paid for. 

 

It isn't able to reliably sustain under load the base (2.2GHz) frequency that it was advertised with.

(Except, for some unknown reason, for 1 or 2 hours on sunday)

 

I am not prepared for this to drag on any longer, and I hope HP are sympathetic to that. 

 

I bought from HP because I believe(d) them to be a large, consumer friendly organisation with a good reputation.

 

I genuinely hope this will be resolved by good customer service, without the need to fall back on legal consumer rights.

 

But, really, enough is now enough.

Reply
0 Kudos
Banjomx
Level 2
15 15 0 4
Message 40 of 47
44
Flag Post
HP Recommended

Spectre Bios F.31 really killing performance

Hi Anon, that's unfortunate. Maybe you can try keeping HwInfo open and check motherboard temps. In the old (good) F22, the fans where linked to this temperature instead of the CPU: as soon as it reached 40°C, fans did start. It was not optimal, but was acceptable. In later BIOS revisions it requires a much higher temperature to allow the fans to start (above 65°C according to my tests, which is way too high and they never spin, leading to a throttled scorching CPU).

 

Do some test keeping an eye to it, you may find the same bahaviour as well as the trigger temperature. This would explain why the performance drops on fresh start: unit is cool = fans off, cpu overheat and goes in throttling. While internally it reaches 90+ degrees, it takes time to propagate the temperature to other components, especially with the fan turned off.

 

Try a game too. When the dedicated GPU is running, fans should start and the cpu should run full speed.

Check also the throttling source: power or temps? In all my tests, it's always caused by temps (power limit can lock max frequency to 3.6GHz, no lower).

 

A precise tracking of the problem may help when communicating with support....no hopes honestly.

 

Anyway, which version of the bios u got back?

If it's above F22 i suggest u to try a flashback to this revision. It's the best i ever had. It may work if rollback was not locked intentionally.

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation