cancel
Showing results for 
Search instead for 
Did you mean: 
hanybabu
New member
2 1 0 0
Message 1 of 5
2,871
Flag Post
HP Recommended

Solved!

i3 7th gen 4gb ram system too slow

hp laptop
Microsoft Windows 10 (64-bit)

i just bought a laptop with i3 7th generation processor and 4 gb ram. the system is so slow that it takes 90 seconds to load ms office. even web browsers take close to 30 seconds. is it the normal speed or is my system super slow? 

4 REPLIES 4
Level 15
Level 15
9,746 9,695 1,902 3,620
Message 2 of 5
2,853
Flag Post
HP Recommended

Solved!

i3 7th gen 4gb ram system too slow

Hi,

It is not a normal speed. Try going into settings > update and security > click on verify fr updates. Let the PC completely update, a couple of reboots might be necessary.

You can also check if the latest version of Windows 10 is installed by pressing Winkey + R and typing winver  If you have version 1803 you could update to version 1809 by going to Microsoft page and click on "Update Now". Follow the installation and after installing the latest version let it completely update.

https://www.microsoft.com/en-us/software-download/windows10

Next, go into HP support assistant by clicking on the symbol in the lower right of desktop or searching for the application in Start. Completely update the PC using the application.

https://support.hp.com/si-en/document/c03467905

 

Hope it helps,

David

hanybabu
New member
2 1 0 0
Message 3 of 5
2,837
Flag Post
HP Recommended

Solved!

i3 7th gen 4gb ram system too slow

thanks, david! 

that really helped. the performance has improved tremendously now!

best!

hany.

Reply
0 Kudos
Level 15
Level 15
9,746 9,695 1,902 3,620
Message 4 of 5
2,808
Flag Post
HP Recommended

Solved!

i3 7th gen 4gb ram system too slow

You're welcome Hani.

Let me know if you need any further help.

 

All the best,

David

 

Reply
0 Kudos
Jajati
New member
1 1 0 0
Message 5 of 5
497
Flag Post
HP Recommended

Solved!

i3 7th gen 4gb ram system too slow

Hi Team,

My pc is running very slow, I am unable to work anything. it's taking minimum booting timing 90 sec, while browsing it's take 30 sec to open.

I have windows version 1903.

Could you help please.

Thanks

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation