cancel
Showing results for 
Search instead for 
Did you mean: 
janny_87
New member
4 3 0 0
Message 1 of 8
647
Flag Post

Solved!

HP Support Assistant closes when trying to start it.

HP Recommended
OMEN by HP - 17-an014ng
Microsoft Windows 10 (64-bit)

So for a while now I have issues with the HP Support Assistant.

If I remember right there was some mess going up with the Assistant Update because the HP Omen Command Center required a newer version that was just available on the Windows App Store somehow. So I had somehow ended up with two assistants installed on my system, but none of them started.

I tried everything I know to try to get it fixed, but no success. Even was in a state where I couldn't even install any HP Support Assistant version. It always told me that  a newer version was already installed, altough it wasn't.

There was no entry in CLASSES_ROOT/Installer/Products nor in LM\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall.

 

Somehow got around it my editing the version in the nstallHPSA.exe.config to a higher version. It then uninstalled whatever leftovers. Was then able to install a 8.x version which seems deprecated though, does not show any software updates.

 

When I try to install a 9.4 .xversion it still complains that  a newer version is installed. That one I can download from the software and drivers section from the hp homepage under my product.

 

Installing the 9.6.x version works though....but there jus the splash screen pops up for 3 seconds then it closes.

Checked the EventViewer for a log message, but nothing.

 

Where is HSA checking for installed versions? Searched through the registry and couldn't find any traces related to HSA.

Must be some file in the system?

1 ACCEPTED SOLUTION

Accepted Solutions
Riddle_Decipher
HP Support Agent
HP Support Agent
31,166 31,117 2,618 3,995
Message 4 of 8
Flag Post
HP Recommended

@janny_87 Even though you already uninstalled reinstalled try it this way for me.

 

First, uninstall your current version of HP Support Assistant by using the Microsoft 'Fixit' on the following link - this is particularly useful in correcting issues that may prevent reinstallation on machines running a 64bit OS: Click here

 

When this has completed, restart the notebook.

 

Next download and install the latest version of HP Support Assistant from the page on the link below - the download links are towards the bottom of the page.

Click here

 

If you wish to thank me for my efforts, you could click on "Accept as solution" on my post as the solution should help others too.

Riddle_Decipher
I am an HP Employee

View solution in original post

0 Kudos
7 REPLIES 7
Riddle_Decipher
HP Support Agent
HP Support Agent
31,166 31,117 2,618 3,995
Message 2 of 8
Flag Post
HP Recommended

@janny_87 Could you create a new user account and check if that works fine?

Did you know that HPSA redirects application updates based on model-series and is not specific to your computer?

 

(Basically, the application gets updates based on the entire series, is not specific to your serial number, hence there are certain updates that can be skipped)

 

Although, if your applications aren't working and the updates are necessary, make sure you download the latest version available for HPSA from the Official HPSA website.

If yes, please follow the below steps to ensure the options are not set to Never :

  1. Open HP Support Assistant and click the Settings button.
  2. On the Health Analysis tab, select "Every day or week" from the Frequency drop-down list, and then click Save.
  3. Click the Tune up tab, select the "your preference" from the Frequency drop-down list, and then click Save.
  4. Restart the computer and try again.

for more details, click here

 

P.S: Welcome to HP Community 😉

 

Let me know how that pans out,

If you feel I was helpful, simply click on Accept as Solution to help the community grow,

That said, I will have someone follow-up on this to ensure you've been helped,

Just in case you don't get back to us, 

have a good day, ahead.

Riddle_Decipher
I am an HP Employee

janny_87
Author
New member
4 3 0 0
Message 3 of 8
Flag Post
HP Recommended

Hey, thanks for your reply.

 

I tried it with a new User Account, no success.

Still didn't start.

 

I uninstalled all HP stuff now, deleted app HP related folders manually and also went to the registry and deleted most of HP related stuff.

 

I can install the 8.x version fine. The 9.4.x tells me that a newer software is installed, the 9.6.x installs too, but does not start.

The 9.6.x is a Windows (Store) App, right? The  Support Framework still installes to C:\ProgramFiles\HP but the actual HSPA to C:\ProgramFiles\WindowsApps.

 

Even deleted two folders there by recursively taking ownership of folder and files before to be able to delete them. Because they were owned by SYSTEM before.

Still can't install the 9.4.x version =/, still tells me a never version is installed, but what causes that?

After deleting the windows apps folders I now cant even install the latest HSPA version. installer crashes with error code -2.

Seems I completely messed up now, lol. 8.x still installs and starts fine though.

 

0 Kudos
Riddle_Decipher
HP Support Agent
HP Support Agent
31,166 31,117 2,618 3,995
Message 4 of 8
Flag Post
HP Recommended

@janny_87 Even though you already uninstalled reinstalled try it this way for me.

 

First, uninstall your current version of HP Support Assistant by using the Microsoft 'Fixit' on the following link - this is particularly useful in correcting issues that may prevent reinstallation on machines running a 64bit OS: Click here

 

When this has completed, restart the notebook.

 

Next download and install the latest version of HP Support Assistant from the page on the link below - the download links are towards the bottom of the page.

Click here

 

If you wish to thank me for my efforts, you could click on "Accept as solution" on my post as the solution should help others too.

Riddle_Decipher
I am an HP Employee

View solution in original post

0 Kudos
janny_87
Author
New member
4 3 0 0
Message 5 of 8
Flag Post
HP Recommended

Thanks for the suggestion, tried that before already, didn't help.

 

I currently do not have any version installed. Only version I can install is the 8.x

Installing 9.4.x tells me that a never version is already installed. the latest 9.6.x errors our with error code -2.

This error is new after deleting the HSPA from C:\ProgramFiles\WindowsApps.

Seems I made it worse that it was before (-:

 

..while writing I finally FIXED it!.

 

I noticed that the UninstallHPSA.exe that gets extracted from the installer with all other files to C:\swsetup

does not run with elevated rights, there is also no UAC Icon on it.

The one in the HSPA8x subfolder has it though.

Maybe thats because the 9.x version is a Windows Store App, and the windows store already runs with elavated rights?

Well, whatever. I simply ran the UninstallHPSA.exe with admin rights and then a dialog appeared if I want to keep hspa related settings or not, I clicked NO.

 

Now I installed the version that HSPA version:  9.4.105.0. Thats the one that I can download from the software and driver page of my model: https://support.hp.com/de-de/drivers/selfservice/omen-by-hp-17-an000-laptop-pc/15551440/model/170623...

 

And it finally installed and started!!!

Tried the latest one from the from the HP homepage too then...but the same issue still. Short splash screen, then it closes.

Also tried to update it from the App Store. same issue. I'll just stay on the older version.

 

 

0 Kudos
Riddle_Decipher
HP Support Agent
HP Support Agent
31,166 31,117 2,618 3,995
Message 6 of 8
Flag Post
HP Recommended

@janny_87 That's awesome, I'm glad you've got it under control,

And until there's a newer version available (that contains a fix for such issues as I'm sure others may have reported it out as well), you can stick to the current version you've installed as it works fine.

 

If you wish to thank me for my efforts, you could click on "Accept as solution" on my post as the solution should help others too.

Riddle_Decipher
I am an HP Employee

janny_87
Author
New member
4 3 0 0
Message 7 of 8
Flag Post
HP Recommended

Done.

 

Seems my solution is a bit more complex though. Tried to install the new version again, didn't start ofc.

Then uninstalled it and couldnt install the 9.4.x again, told me a newer version is installed.

Running the uninstallhspa.exe with elevated rights didn't do anything either.

So I went though the registry again and deleted all registry keys that containd "hewlett".

After that uninstallhspa.exe  worked again, showed me a popup if I want to keep the settings, clicked no and then I was able to install the 9.4.x version. 

There seems to be definitely something off with the uninstaller not cleaning the registry properly.

 

Thanks for your effort and time though, much appreciated.

 
0 Kudos
Riddle_Decipher
HP Support Agent
HP Support Agent
31,166 31,117 2,618 3,995
Message 8 of 8
Flag Post
HP Recommended

@janny_87 You are right, it looks like there's something off about it, and I've reported the same to the R&D team,

Also, i appreciate the details you've provided so far, have a good day, ahead.

Riddle_Decipher
I am an HP Employee

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation