• ×
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
  • ×
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
Check out our WINDOWS 11 Support Center info about: OPTIMIZATION, KNOWN ISSUES, FAQs, VIDEOS AND MORE.
HP Recommended
HP Spectre x360
Microsoft Windows 10 (64-bit)

My laptop is having problems with internet connectivity. Here are the symptoms:

 

- Windows 10 is installed

- Soon after recognizing and connecting to my preferred Wi-Fi network, the network icon in the Start Menu shows "No Internet Access" 

- All apps on the laptop are unable to access the internet

- Google Chrome shows the following error code: DNS_PROBE_FINISHED_NO_INTERNET

- When I run Windows Network Diagnostics, Troubleshooting finds the following problem: "The default gateway is not available" and the problem is listed as "Fixed" with a green check next to it. However, nothing is actually fixed.

- Other devices are connected to the network with a very strong, working connection. No internet problems whatsoever.

 

I've tried scanning my system for an update to the Wi-Fi driver but it says I already have the latest version. This started happening out of nowhere, not after a sketchy installation or anything like that. One day it just stopped working.

 

Should I uninstall and re-install the wireless-AC driver? What happens if I uninstall the driver, restart my system and it doesn't manage to re-install the driver? That would leave me with a different problem but before I attempt that, is there anything else that I should try first?

2 REPLIES 2
HP Recommended

UPDATE:

 

The laptop does seem to run internet fine with another network (I activated my phone's hotspot and it had no issues) so now I'm thinking it has something to do with my Wi-Fi network in my apartment. Any advice on things I could try? 

HP Recommended

Hi, did you manage to fix this? I'm having the same issue out of nowhere. Nothing seems to be working.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.