cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
emailpat
New member
3 3 0 0
Message 11 of 25
Flag Post
HP Recommended

Change User Account Control Settings not work for HP Laserjet Pro 127fn.

Looks like PCL/m printer driver issue.

 

 

Was this reply helpful? Yes No
Gemini02
Retired
Retired
16,806 16,907 1,042 2,651
Message 12 of 25
Flag Post
HP Recommended

Hi @emailpat,

 

I see that you are experiencing issues printing on the User Accounts.

 

I have provided a document for how To set or remove permissions for a printer.

 

If you are still having issues, please contact Microsoft for further assistance. Thank You.

Gemini02

I work on behalf of HP

Click the Thumbs Up below to say “Thanks” for helping!
Was this reply helpful? Yes No
emailpat
New member
3 3 0 0
Message 13 of 25
Flag Post
HP Recommended

Hi Gemini02,

 

I have tested already, grant end user printer full admin -- no work

 

Looks like PCLm drive issue.

 

 

 

Was this reply helpful? Yes No
Gregozilla
New member
1 1 0 1
Message 14 of 25
Flag Post
HP Recommended

I just purchased an OfficeJet Pro 6830 I'm facing the exact same problem on Windows 7.

Disabling UAC works but it's not an acceptable solution, UAC should never be disabled.

Please provide another solution, as it seems that we are many to have this problem with HP printers.

Was this reply helpful? Yes No
Dax_Little
New member
1 1 0 2
Message 15 of 25
Flag Post
HP Recommended

I've also bought OfficeJet Pro 6830 last week for my company and i have problems when printing from Office 365 (2016), my OS is Windows 10, if i run Word as an admin then i can print, but if i double click a docx file it won't orint, so printing is not possible with HP, other brands have no problems when double clicking files... i don't need to set any permissions or what so ever on other brands....

 

I tried disabling UAC, setting permissions, i tried everything in here, out there, even what will be done in the future.... but no luck,,,  I am so  unhappy with this purchase!

 

I don't have these kind of problems with other manufacturers, i can print with lexmark, epson, xerox, etc... no problems there...

 

Please, help!

 

 

I have found a workaround, BUT IT IS NOT SAFE:

 

GO TO: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

and change EnableLua to 0

Was this reply helpful? Yes No
MrsFixIt12
New member
1 1 0 0
Message 16 of 25
Flag Post
HP Recommended

We have found changing it to the PCL 6 driver instead of a model specific driver will allow non-administrative accounts to print.  This is an issue we have seen in our enterprise across multiple models of HP printers but specifically with these models : 402n, color laserjet 452n.  

 

Let me know if that works for anyone else!

 

 

Was this reply helpful? Yes No
clh42
Level 3
3 3 0 37
Message 17 of 25
Flag Post
HP Recommended

I'm having the same problem with a newly purchased M477fdn MFP.

 

Another odd thing I notice.

 

When I first right-click on the printer and go into printer properties, all my options are grayed out, but there is a UAC "Change Properties" button.  If I click that, then do a Print Test Page from there, the Windows test page prints just fine.

 

So I checked up on security.  My account is not listed on the Security tab (but the Administrators group is, and my account is a member of Administrators).  Just to try something, I added my account specifically to the security for the printer with Print, Manage this printer, and Manage document permissions.  After that, I close the printer properties, right-click on the printer and select Printer Properties again, and this time the UAC "Change Properties button is missing, and I immediately have the ability to change settings on the printer.  But guess what?  The test page will NOT print, and apps like Word still won't print either unless I still specifically run them as administrator.

 

But if remove myself from the printer security again, and close and reopen the printer properties, the UAC Change Properties button is back, and again, if I click the UAC button, then print test page, the test page prints.

 

So it's like it's forcing access to the printer through actual UAC elevation, even if somebody is already still a full admin.

Was this reply helpful? Yes No
clh42
Level 3
3 3 0 37
Message 18 of 25
Flag Post
HP Recommended

Well, I figured my issue out, with a bit of help from earlier in this thread, and another thread I found on the same topic.

 

The weird thing is, I've never had this issue with any other printer, and I've had 4 or 5 other printers installed on this PC, under this user account, in the past and never had this issue.  I don't know why I suddenly had the issue with this specific printer driver (my new MFP M477fdn mentioned in my previous post).

 

The short answer...

 

This is more likely to be the cause if you have changed the location of your User "TEMP" directory from Microsoft's default, but it's worth a double-check even if you haven't.

 

Find your USER "TEMP" directory (by default is %USERPROFILE%\AppData\Local\Temp, but if you moved it, then wherever you moved it to), and make sure the user account you're logged in with is explicitly assigned to the NTFS security on the TEMP folder with Full Control permissions.  Even if the user account you're logging in with is a member of the administrators group or any other group that has full control on the directory, make sure the user account is explicity assigned in addition.  Do not rely on the group permissions.

 

Apparently, by using the inherited rights through the group permissions, that's what triggers and requires the UAC elevation.  By adding the user explicitly to the folder permissions, the user account then has inherent full permissions without needing to inherit them through group membership, and this then bypasses the need for UAC elevation.

 

How did I discover this? ...

 

On my PC, I redirect the TEMP directory from the Microsoft default, to an alternate location, D:\TEMP, to get it off of my system drive.

 

I had read earlier in this thread, and in another thread, about checking permissions on the Temp folder, but those posts suggested granting the Everyone group full permissions on Temp.  I tried that and it did not work.  But it did give me the hint that my problem might be related to the Temp directory.

 

I created a new local account on my PC and logged in with that.  The printer actually printed fine.  Of course, when I created and logged in as the new account, it started out with the default MS Temp dir location under its own user profile directory.

 

I then changed the TEMP and TMP environment variables in the new user account to also point to my D:\TEMP location.  Guess what?  The printer then failed to print.  I then changed the TEMP and TMP variables in my new account back to point the MS default Temp directory under the user profile.  The printer printed again!  AH HA, indeed related to the Temp directory.

 

So then I checked permissions on the new Temp directory under my new user account profile, vs. the permissions I had on my alternate D:\TEMP directory.  Both had Administrators and System assigned with Full Control.  The only difference was that the Temp directory under the user profile had that user explicitly assigned to it with Full Control, and my D:\TEMP directory did not have any users assigned directly to it, only the Administrators and System groups.

 

SO, I added the new test account explicitly to my D:\TEMP directory permissions with Full Control.  Then I changed the TEMP and TMP environment variables in my test account back to D:\TEMP, and viola, the printer still printed!

 

SOOOO, then I added my original account explicitly to the D:\TEMP permissions with Full Control.  I logged out of the test account and back in as my orginal accound, and again, viola, the printer printed without having to do the UAC elevation!

 

Again though, I have no idea why the original config (without explicit user permissions on D:\TEMP) worked for all other printers I've ever had and only just failed with this new M477fdn printer driver.  But it's working now!

 

 

Was this reply helpful? Yes No
Marian-Octavian
Level 1
1 1 0 4
Message 19 of 25
Flag Post
HP Recommended

Active Directory Network

 

  1. You need to give full permissions to Authenticated Users interactive group to the new %TEMP% path: ex: C:\TEMP if you are in a Active Directory Domain.

 

Tags (1)
Was this reply helpful? Yes No
clh42
Level 3
3 3 0 37
Message 20 of 25
Flag Post
HP Recommended

Since my original post above about adding the user account itself directly, I've discovered that it also works by granting the Users group Full Control to the Temp directory, instead of the user account itself.

 

So it will work with the Users group, but will not work by inheriting from the Administrators group, and Everyone did not work for me either.

 

Or as Marian-Octavian reported, Authenticated Users may also work.  I didn't try that.  Marian-Octavian reported using Authenticated Users in a domain environment.  My situation is a standalone home computer.

Was this reply helpful? Yes No
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation