cancel
Showing results for 
Search instead for 
Did you mean: 
New member
1 0 0 0
213
Flag Post
HP Recommended

AirPrint stopped working with macOS 10.15

HP OfficeJet Pro 8600
macOS 10.15 Catalina

My HP OfficeJet Pro 8600 has worked perfectly for years using AirPrint (Bonjour). Recently it has stopped working and I can no longer AirPrint via my iOS devices or through my Macbook(s) - all running macOS 10.15.

 

macOS (MacBooks)

When attempting to print through macOS 10.15, the job will go to the queue and just sit there with message "Printing - Connecting to Printer" but the job never completes. I have tried this on 3 different MacBooks. I removed the printer in System Settings and then attempted to add it back. I can see the printer and select it with "Use: AirPrint" and it will attempt to set up, but then it will throw an error:

 

Error.png

 

iOS (iPhones & iPads)

When attempting to print through iOS, I can see and select the Officejet Pro 8600 in the print dialog and it will say "Printing to Officejet Pro/Contacting Printer" but will never print the job.

The following has evaluated to null or missing: ==> page.context.thread [in template "gz-hp.custom.reply.metoo" at line 4, column 22] ---- Tip: It's the step after the last dot that caused this error, not those before it. ---- Tip: If the failing expression is known to be legally refer to something that's sometimes null or missing, either specify a default value like myOptionalVar!myDefault, or use <#if myOptionalVar??>when-present<#else>when-missing. (These only cover the last step of the expression; to cover the whole expression, use parenthesis: (myOptionalVar.foo)!myDefault, (myOptionalVar.foo)?? ---- ---- FTL stack trace ("~" means nesting-related): - Failed at: #assign threadId = page.context.threa... [in template "gz-hp.custom.reply.metoo" at line 4, column 1] ----
Who Me Too'd this topic
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation