cancel
Showing results for 
Search instead for 
Did you mean: 
RSTNL
New member
2 1 0 0
Message 1 of 4
1,650
Flag Post

Cannot connect anymore with Snapdragon X5 LTE in Elite X2 1012 G1

HP Recommended
HP Elite x2 1012 G1
Microsoft Windows 10 (64-bit)

Since some time I am unable to connect to my cellular network. I'm not sure exactly what caused the change or when exactly it stopped working since I regularly work in Wifi.

 

Symptoms:

  • When I try to connect using Windows, I get the message that an APN is needed (before the 'default' APN worked fine).

APN-Message.PNG

 

  • Using the Vodafone Mobile Broadband app, I get the message that the connection has failed with the suggestion to make sure that the device is not used by other programs
  • Running the HP Network Check  there is a finding that says that the SIM or Device are locked with reference to a Pin2.

Network-Diag.PNG

  • The driver details show that the Generic Microsoft driver is used (and not the driver I expected), and the evenlog shows a 'Device not Migrated message'. 

Driver-Details.PNGDriver-Events.PNG

 

Actions tried

  • I tried multiple (Vodafone) SIMs.
  • I updated the drivers and (notebook) firmware to the laters version through the HP Support Assistant (which might as well have been the cause, since I regularly do this). Also Windows is completely up-to-date.
  • I rolled back to a restorepoint from two months ago.
  • I removed the HP drivers manually and reinstalled manually (sp89031).
  • I tried switching the LTE modem firmware to generic and then back to vodafone.

 

I'm out of options here. Anyone who can help?

 

3 REPLIES 3
soccer_dan
Level 8
Level 8
1,195 1,195 74 154
Message 2 of 4
Flag Post
HP Recommended

make sure the WWAN card's f/w is up to date and you have the latest drivers... i would then contact Vodafone as this may be an issue with your WWAN data account

I work for HP. However, all opinions and comments are my own.
0 Kudos
RSTNL
Author
New member
2 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Hi,

 

thanks for the reply.

 

The firmware is the latest available, and so are the drivers. I use the ones provided by HP.

 

The dataplan is also not the issue here. I switched the sim-card and also with another card (which functions properly in another device) the error occurs.

 

Any thoughts on the specific message's / errors / findings I mentioned in my initial post?

 

Best regards

0 Kudos
Dayweeeed
New member
1 1 0 0
Message 4 of 4
Flag Post
HP Recommended

  Hello. I exactly experienced the same issue today. Suddenly my internet was gone and written “no internet”. I didnt install any update recently. My drivers are the latest version. But I dont know what happened suddenly and it atopes working.

I tried every way that I knew but again no internet and when diagnosed it said “enter a sim card pin2 to unlock your broadband device”. I replaced the sim with another sim but same error. I put the sim in another device and it worked so the sim card is working. 

So after I tried many ways and failed I did system restore and after that everything worked fine. Still I dont know what caused the problem and what solved the problem. 

I really afraid if this problem cones again and system restore couldnt aolve the problem 

please let us know if you find the solution. 

My device is Hp elite x2 g1 -snapdragone x5 lte -win10 -all drivers and windows 10 are up to date. 

Please help.....

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation