cancel
Showing results for 
Search instead for 
Did you mean: 
mmc_
Level 1
3 2 1 1
Message 1 of 13
63,747
Flag Post

Solved!

HP Thunderbolt Dock G2 230w: No eth and USB

HP Recommended
HP Thunderbolt Dock G2 230w
Microsoft Windows 7 (64-bit)

Hello, we're seeing an issue where the HP Thunderbolt Dock G2 230w (3TR87AA#ABA) is failing to connect USB devices and ethernet. There is one device throwing a driver code, please refer to the following hardware IDs. We're attempting to deploy these docks with our existing HP zBook 15 G2. Drivers listed on the website for a similar dock and those updated by the SDM weren't able to resolve the issue. 

PCI\VEN_8086&DEV_15EC&SUBSYS_0467103C&REV_06
PCI\VEN_8086&DEV_15EC&SUBSYS_0467103C
PCI\VEN_8086&DEV_15EC&CC_0C0330
PCI\VEN_8086&DEV_15EC&CC_0C03

 

Any assistance is appreciated

1 ACCEPTED SOLUTION

Accepted Solutions
mmc_
Author
Level 1
3 2 1 1
Message 6 of 13
Flag Post
HP Recommended

It was the USB eXtensible USB 3.0 and 3.1 drivers for us. I uninstalled in devmgmt, then reinstalled with the HPIA driver\firmware utility and it decided to detect the entire dock after that

View solution in original post

12 REPLIES 12
David_J_W
Level 7
917 915 89 267
Message 2 of 13
Flag Post
HP Recommended

Those devices are Intel Thunderbolt controllers. Is the Thunderbolt software and BIOS on the ZBooks up to date?

0 Kudos
mmc_
Author
Level 1
3 2 1 1
Message 3 of 13
Flag Post
HP Recommended

Up to date with the latest as provided from the HP support site

0 Kudos
gt9
Level 1
1 1 0 3
Message 4 of 13
Flag Post
HP Recommended

Hello, in my case what worked is to install from HP the Thunderbolt drivers. After that i had to run the "Thunderbolt Software" which is installed with the drivers. When you run the "Thunderbolt Software" you have to be connected to the dock and then inside the sofware you have to allow the connection with the device. Then reboot.

MartinD2
New member
2 2 0 1
Message 5 of 13
Flag Post
HP Recommended

I have the exact same issue.

 

I tried updateting all dirvers, BIOS, re-installing everything, change in BIOS through all thunderbolt options and it is not wokring.

 

I have a ZBook 15 G3 ( all my colleauges have this configuration and the issue there is the same)

 

There is no firmware update available for Thunderbolt Dock G2 230W.

 

Please share if you have a solution to this.

Tags (1)
mmc_
Author
Level 1
3 2 1 1
Message 6 of 13
Flag Post
HP Recommended

It was the USB eXtensible USB 3.0 and 3.1 drivers for us. I uninstalled in devmgmt, then reinstalled with the HPIA driver\firmware utility and it decided to detect the entire dock after that

View solution in original post

MartinD2
New member
2 2 0 1
Message 7 of 13
Flag Post
HP Recommended

Hi Mmc_

 

I tried this but it had no effect.

 

Infact deleting the drivers and then installing them using the HP Assistant, it caused a BSOD which was not possible to solve and we had to re-install winwows.

 

 

0 Kudos
ThatOneTechGuy
New member
1 1 0 1
Message 8 of 13
Flag Post
HP Recommended

I just came across this post hoping to resolve a missing ethernet connection and stumbled across a resolution.

 

In my case I had to run the Thunderbolt software that was installed when the dock was connected, then I right-clicked on the running tray icon > Manage Approved Devices. Once I opened that up it asked me to approve the connection of the dock and everything worked as expected.

 

Weird how everything else worked except the ethernet, kudos to Gt9 for mentioning the software. Didn't even think about it.

SandiXP
New member
1 1 0 0
Message 9 of 13
Flag Post
HP Recommended

In my cas I already had the software install, but it was set as "Do Not Connect" I jsut has to change it to "Conect Always" woked as dream.... Thanks!

0 Kudos
TimGrissom
Level 1
5 4 0 3
Message 10 of 13
Flag Post
HP Recommended

We were experiencing this same problem and were finally able to fix it by opening the "Attached Thunderbolt Devices" window from the tray, selecting HP Thunderbolt Dock G2, and then at the bottom after Connection Status, it said "Not Connected" in blue.  I clicked on the blue words and it gave me the option to choose when to connect.  I selected always connect and that fixed everything.

 

Capture.PNG

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation