cancel
Muhilla Top Student
Top Student
4 2 0 1
Message 1 of 6
3,709
Flag Post
HP Recommended

Upgraded PSU, but fan not working, NEVER spins.

Pavillion 590-p0066
Microsoft Windows 10 (64-bit)

Hello! I upgraded my PSU from 310W SFF to a 400W SFF, purchased from HP Parts, to accomodate a new graphics card. Everything works great, but about once a day the computer just shuts off. I have to unplug the power supply for a few minutes and reconnect then restart. The graphics card is staying cool and fans are functioning properly. I have noticed, however, that the PSU fan NEVER spins at start up, at shut down, during operation, never. This power supply, like the original 310W, has the proprietary 7 pin motherboard connector. The difference is that the original PSU only had 3 actual wires on the 7 pin connector while the 400W has a ll seven filled. Could the extra 4 wires be causing a communication problem with the motherboard, or did I just get a defective PSU?  What are the other 4 wires used for? Any help you can give would be appreciated. Thanks.

5 REPLIES 5
Provost Provost
Provost
10,382 9,759 1,324 3,577
Message 2 of 6
3,685
Flag Post
HP Recommended

Upgraded PSU, but fan not working, NEVER spins.

@Muhilla,

Congratulations on being the first person to report you found a link within HP for a 400W PSU that was supposedly suitable for the HP 590 series computer with a LINCS motherboard.  Could you post the link,  as HP PartsSurfer does not list any other PSU but the 310W.

This system is feedback driven thru Solution and Kudo flags. It's the only means of knowing if you have been served. Please click Accept as Solution, if your problem is solved. To say THANK YOU, press the "thumbs up symbol" to render a KUDO. You can render both Solution and KUDO..

HP Envy 8 5010 Tablet
(2) HP DV7t i7 3160QM 2.3Ghz 8GB
Printer -- HP OfficeJet Pro 8620 Legal
Custom Asus Z97D, I7-4790k, 16GB RAM, WIN10 Pro 64bit, ZOTAC GTX1080 AMP Extreme 3 fan 8GB RAM, 500GB SSD, Asus PB287 4k monitor, Rosewill Blackhawk case and 750W OCZ PSU.
Highlighted
Muhilla Top Student
Top Student
4 2 0 1
Message 3 of 6
3,663
Flag Post
HP Recommended

Upgraded PSU, but fan not working, NEVER spins.

Thank you for your response.  An update to my problem. I updated my BIOS this morning, and I have not had a spontaneous shut down since. The fan still has not turned on to my knowledge. Does it need to reach a certain temperature in order for the fan to turn on or is it supposed to be on? Here is the link to the PSU: 

https://parts.hp.com/hpparts/Search_Results.aspx?mscssid=E2DE572849C240C0B41302989018C9BB&SearchIn=P...

 

Part number is L04618-800

 

Provost Provost
Provost
10,382 9,759 1,324 3,577
Message 4 of 6
3,359
Flag Post
HP Recommended

Upgraded PSU, but fan not working, NEVER spins.

@Muhilla,

Your link should have opened a world of possibility for all owners of these units.

Alas, the inline 7 pin should have only 3 wires according to the photo's submitted by chris, see here.  Just scroll down to the actual pictures. It clearly shows the 3 wires on a 7 pin socket.

 

Why HP offers a replacement PSU (correct part number) with improper wiring is beyond my un-paid  level.

This system is feedback driven thru Solution and Kudo flags. It's the only means of knowing if you have been served. Please click Accept as Solution, if your problem is solved. To say THANK YOU, press the "thumbs up symbol" to render a KUDO. You can render both Solution and KUDO..

HP Envy 8 5010 Tablet
(2) HP DV7t i7 3160QM 2.3Ghz 8GB
Printer -- HP OfficeJet Pro 8620 Legal
Custom Asus Z97D, I7-4790k, 16GB RAM, WIN10 Pro 64bit, ZOTAC GTX1080 AMP Extreme 3 fan 8GB RAM, 500GB SSD, Asus PB287 4k monitor, Rosewill Blackhawk case and 750W OCZ PSU.
Reply
0 Kudos
Moderator
Moderator
2,590 2,541 155 469
Message 5 of 6
3,348
Flag Post
HP Recommended

Upgraded PSU, but fan not working, NEVER spins.

@Muhilla

 

I have brought your issue to the attention of an appropriate team within HP. They will likely request information from you in order to look up your case details or product serial number. Please look for a private message from an identified HP contact. Additionally, keep in mind not to publicly post personal information (serial numbers and case details).

If you are unfamiliar with how the Support Community's private message capability works, you can learn about that here.

Thank you for visiting the HP Support Community.

I work on behalf of HP
Reply
0 Kudos
Muhilla Top Student
Top Student
4 2 0 1
Message 6 of 6
2,549
Flag Post
HP Recommended

Upgraded PSU, but fan not working, NEVER spins.

@WB2001

 

Thanks for the response. At the moment I would say my 400W PSU solution is not an easy one and it is not complete. I have HP trying to help me, but in the mean time I figured I would give an update. I think the 400W PSU I got from HP Parts (Part #-L04618-800)  connects to the motherboard with  3 extra wires in the 7 pin proprietary connection. These extra 3 wires must act like a switch to cause the fan to spin at different rates depending on use and temperature I would assume. The motherboard does not like these extra 3 wires and the fan will not spin. In my attempts to mess with the wiring on the connector I got the fan to act normal at startup and shutdown (normal on off, but not continuous  by removing one of the wires.  In another instance by keeping just one wite the PSU fan was full out jet engine strong. But no happ median I am afraid. I just wish I could talk to a tech with knowledge of systems to tell me what is going on. Why is that not possible with  HP? I can't even find a schematic of the motherboard or PSU wirring anywhere on the web. that is so abnormal in the computing world.

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation