cancel
Showing results for 
Search instead for 
Did you mean: 
nuinu
New member
2 1 0 1
Message 1 of 4
404
Flag Post
HP Recommended

Update Thinpro 7.1 to sp 3.4 fail

HP t530 Thin Client
Linux

Hello! I try update OS ThinPro 7.1 with  SP 3.4 from HPDM. Task failed with error "ErrorCode: 14004022, Error Detail: Command line error.". In log I see:

2019-09-11 18:05:39 The following packages have unmet dependencies:
2019-09-11 18:05:39 hptc-sp-securityupdate-2019-004-rollup-1.0-thinpro-7.0 : Depends: applespi-4.15.7-hp:amd64 (>= 1.0+git20180314) but it is not installable
2019-09-11 18:05:39 Depends: hptc-bios-cfg-4.15.7-hp:amd64 (>= 4.1) but it is not installable
2019-09-11 18:05:39 Depends: hptc-rgs-usb-4.15.7-hp:amd64 (>= 4.15.7-hp) but it is not installable
2019-09-11 18:05:39 Depends: hptc-touchscreen-4.15.7-hp:amd64 (>= 1.10) but it is not installable
2019-09-11 18:05:39 Depends: iwlwifi-ucode-4.15.7-hp (>= 7) but it is not installable

As I understand SP 3.4 for thinpro 7.1 have some prerequirements for succesful install. Where can i download this packages? How can I install them?

3 REPLIES 3
Level 4 DM-AJ
Level 4
52 51 4 16
Message 2 of 4
361
Flag Post
HP Recommended

Update Thinpro 7.1 to sp 3.4 fail

Hi Nuinu,

the log "hptc-sp-securityupdate-2019-004-rollup-1.0-thinpro-7.0" suggests this is not a package for ThinPro 7.1.  Please be informed that ThinPro 7.0 and 7.1 don't share packages.  Please make sure to apply the correct package for your thin client OS.

I am an HPI Employee.
My opinions are my own and do not express those of HPI.
**Click the Thumbs Up Button below to say Thanks**
nuinu
New member
2 1 0 1
Message 3 of 4
344
Flag Post
HP Recommended

Update Thinpro 7.1 to sp 3.4 fail

Hi DM-AJ,

 

Thanks for reply. Problem was solved after reimage thinclient. Looks like servicepack 3.4 can not be installed after attempt to install "hptc-sp-securityupdate-2019-004-rollup-1.0-thinpro-7.0" on thinpro 7.1.

Auke_DLZ
New member
4 3 0 1
Message 4 of 4
165
Flag Post
HP Recommended

Update Thinpro 7.1 to sp 3.4 fail

Hi,

 

I had this same problem with ThinPro 7.1 and SP5.3.

I updated the agent on a T520 and installed ThinPro 7.1, without updating the agent ThinPro 7.1 failed. Next I updated the agent again, because a lot of tasks fail when the agent is not updated, and tried to install SP5.3 which failed every time.

Then I did a factory reset and immediately after that I installed SP5.3. SP5.3 was successful installed. When I took a closer look why it was working this time, I found out that the Agent was a version lower. The factory reset downgraded the agent.

So I have tested this a few more times and our task sequence looks like this:

- Update agent.

- Install new 7.1 image (in our case T7X71018)

- Install SP 5.3

- Update agent.

Followed by more of the tasks.

This is working perfectly for us.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation