• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
The HP Community is where owners of HP products, like you, volunteer to help each other find solutions.
HP Recommended
Poly Studio X50

Our Poly Studio X50 has recently become very slow. When booting, all animations will display at ~10 frames per second, and when booting to a Zoom Room it will not show a "Pairing Code" in the top-right and will not display the room name in the top-left.

1 ACCEPTED SOLUTION

Accepted Solutions
HP Recommended

I sort of did, yes! The issue was remediated by leaving the X50 powered off overnight. That was able to fix the slowness issue. It is still only displaying part of the Zoom Room Information, but now that it is more responsive, it's close enough for me

View solution in original post

15 REPLIES 15
HP Recommended

Hello @The_Jacob ,

 

Welcome to the HP community.

 

Unfortunately, Your post does not contain the currently used Software version for the HP Poly product or the Partner application you use.

 

This is important especially in the future when someone finds this post in days, months, or years to come.

 

For current Video products please include the Provider used.

 

I would suggest a factory reset of the Unit and the next step would be to work with our support organisation in your region. Details are in my signature.

 

Best regards

 

Steffen Baier

------------------------------------------------
Notice: I am an HP Poly employee but all replies within the community are done as a volunteer outside of my day role. This community forum is not an official HP Poly support resource, thus responses from HP Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
If you need immediate and/or official assistance for former Poly\Plantronics\Polycom please open a service ticket through your support channels
For HP products please check HP Support.

Please also ensure you always check the General VoIP , Video Endpoint , UC Platform (Microsoft) , PSTN
HP Recommended

Hello, thank you for your response. The software version we are using is 4.0.2.348012 (most recent according to Poly Lens) and we have also just factory reset the device and it is still slow. This happens while it is configured as a Teams Room & Zoom Room. I attempted to put in a ticket but the HP portal said the serial number was invalid. Thanks!

HP Recommended

Hello @The_Jacob 

 

that still does not answer what exact provider software version you are using when using a partner Application from Zoom or Microsoft.

 

I suggest you contact support. Details are in my signature.

 

Best Regards

 

Steffen Baier

------------------------------------------------
Notice: I am an HP Poly employee but all replies within the community are done as a volunteer outside of my day role. This community forum is not an official HP Poly support resource, thus responses from HP Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
If you need immediate and/or official assistance for former Poly\Plantronics\Polycom please open a service ticket through your support channels
For HP products please check HP Support.

Please also ensure you always check the General VoIP , Video Endpoint , UC Platform (Microsoft) , PSTN
HP Recommended

Hi Steffen.

 

The Zoom Version that runs slowly is 5.15.7.3484

The Teams Version that runs slowly is 1449/1.0.96.2023031201

HP Recommended

I suggest you contact support. Details are in my signature.

------------------------------------------------
Notice: I am an HP Poly employee but all replies within the community are done as a volunteer outside of my day role. This community forum is not an official HP Poly support resource, thus responses from HP Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
If you need immediate and/or official assistance for former Poly\Plantronics\Polycom please open a service ticket through your support channels
For HP products please check HP Support.

Please also ensure you always check the General VoIP , Video Endpoint , UC Platform (Microsoft) , PSTN
HP Recommended

Did you ever get a resolution for this?

HP Recommended

I haven't seen this issue, but PolyOS 4.1 is available now so I would recommend upgrading if you haven't already.

HP Recommended

I sort of did, yes! The issue was remediated by leaving the X50 powered off overnight. That was able to fix the slowness issue. It is still only displaying part of the Zoom Room Information, but now that it is more responsive, it's close enough for me

HP Recommended

You most likely have the HDMI cable running to the display plugged into HDMI out 2 on the polycom X50. You should make sure to plug it into HDMI out 1. Plugging into HDMI out 2 will cause the slowness you were experiencing and the zoom screen to not display properly.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.