• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
Be the first to explore and join the conversation on our brand-new Poly Support Community Blog, Click here It's live now!!
HP Recommended

Hello,

New poly x30 and TC8 and trying to use teams provider. 

i had to incrementally update studio (3.2.3, 3.4, 3.7, 3.14current) using the USB method but the TC8 is stuck at 3.0.0 and while it says it is paired (on web browser and TC8 HMI), it says waiting for pairing on the TC8 Screen. The TC8 is 3.0.0 and says "incorrect software version detected" anytime I tried to do an update (i went back to usb updates and just copied touchcrtl and softwareupdate.cfg and they all failed with same message).

I'm at a lost to how to get this to update so it functions with teams. (it works when provider is poly). I have factory reset the TC8 multiple times and nothing changes. 

image

 

7 REPLIES 7
HP Recommended

Hello @kdelawder ,

 

Welcome to the Poly Community.

Most likely you will need to downgrade the Studio X to 3.0.0 and then pair the TC8

 

With the TC8 paired go to 3.2.3 and upgrade. From there it should be fine. If you still struggle the best and quickest way forward is to contact our Support organisation as the community is run by volunteers only.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

------------------------------------------------
Notice: I am an HP Poly employee but all replies within the community are done as a volunteer outside of my day role. This community forum is not an official HP Poly support resource, thus responses from HP Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
If you need immediate and/or official assistance for former Poly\Plantronics\Polycom please open a service ticket through your support channels
For HP products please check HP Support.

Please also ensure you always check the General VoIP , Video Endpoint , UC Platform (Microsoft) , PSTN
HP Recommended

Hi...

 

I have had simular task.. Had to go from Poly OS 2.x.x to Poly OS 4.x.x

 

I used the Custom server URL option:

image

 

You can find the URL at: update.polydemo.com - Search for G7500

If the endpoint to have internet acces, then you can download the firmware and downgrade the Poly X to Poly OS 3.3.2, Update TC8.

 

In my experience I have 100% success going from 3.3.2 to 3.7.1 to 3.14.2 - Remember to make sure the TC8 is update during the update path.

 

 

Best regards - Dan Hemsø
Poly Video Professional (VIDEO-PRO) UC consultant
Remember mark as "Accepted Solutions" or if my reply/help is "Helpful"
HP Recommended

Good morning. I have tried this, but the TC8 still says incorrect software version detected when upgrading from 3.0.0 to 3.2.3

HP Recommended

I also tried 3.1.0. 

also failed. 

 

I do notice the Poly TC8 reboots almost immediately when starting the update

HP Recommended

Hello @kdelawder ,

 

have you factory reset the TC8 yet?

 

Please get this into support.

 

The best and quickest way forward is to contact our Support organization as the community is run by volunteers only.


Please ensure to provide some feedback if this reply has helped you so other users can profit from your experience.

Best Regards

Steffen Baier

------------------------------------------------
Notice: I am an HP Poly employee but all replies within the community are done as a volunteer outside of my day role. This community forum is not an official HP Poly support resource, thus responses from HP Poly employees, partners, and customers alike are best-effort in attempts to share learned knowledge.
If you need immediate and/or official assistance for former Poly\Plantronics\Polycom please open a service ticket through your support channels
For HP products please check HP Support.

Please also ensure you always check the General VoIP , Video Endpoint , UC Platform (Microsoft) , PSTN
HP Recommended

yes. it has been factory reset multiple times. 

 

HP Recommended

Hi...

 

What version is your Poly X?

 

Best regards - Dan Hemsø
Poly Video Professional (VIDEO-PRO) UC consultant
Remember mark as "Accepted Solutions" or if my reply/help is "Helpful"
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.