cancel
Showing results for 
Search instead for 
Did you mean: 
Common problems HP Solution Center not working : Adobe Flash Player Error and Unable to scan
We would like to share some of the most frequently asked questions about HP Solution Center not working : Adobe Flash Player Error and Unable to Scan.
linux_is_best
Level 2
15 9 1 1
Message 1 of 3
219
Flag Post

HPlip not supported on Ubuntu 20.04, so how do I scan with Envy Pro 6455?

HP Recommended
Envy Pro 6455
Ubuntu LTS

Background: New 6455 connected via USB to a desktop running Ubuntu 20.04.  I can print, but  I  think that  is via the network.

Installing HPlip was a trial, since I am not very geeky and the gui features of HPlip are not supported on  this version of linux.  It may be due to the version of python.  The computer has both ❤️  and 3+, but to invoke 3 requires use of the term python3, which perhaps HPlip does not use.  In any event, I have below the result of hp-check on the hope that it will mean something to someone more skilled than I.

Thanks.

 

hp-check[42586]: info: :
hp-check[42586]: info: :[01mHP Linux Imaging and Printing System (ver. 3.21.2)[0m
hp-check[42586]: info: :[01mDependency/Version Check Utility ver. 15.1[0m
hp-check[42586]: info: :
hp-check[42586]: info: :Copyright (c) 2001-18 HP Development Company, LP
hp-check[42586]: info: :This software comes with ABSOLUTELY NO WARRANTY.
hp-check[42586]: info: :This is free software, and you are welcome to distribute it
hp-check[42586]: info: :under certain conditions. See COPYING file for more details.
hp-check[42586]: info: :
hp-check[42586]: info: :[01mNote: hp-check can be run in three modes:[0m
hp-check[42586]: info: :1. Compile-time check mode (-c or --compile): Use this mode before compiling the
hp-check[42586]: info: :HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
hp-check[42586]: info: :are installed to successfully compile HPLIP.
hp-check[42586]: info: :2. Run-time check mode (-r or --run): Use this mode to determine if a distro
hp-check[42586]: info: :supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
hp-check[42586]: info: :has the proper dependencies installed to successfully run.
hp-check[42586]: info: :3. Both compile- and run-time check mode (-b or --both) (Default): This mode
hp-check[42586]: info: :will check both of the above cases (both compile- and run-time dependencies).
hp-check[42586]: info: :
hp-check[42586]: info: :Check types:
hp-check[42586]: info: :a. EXTERNALDEP - External Dependencies
hp-check[42586]: info: :b. GENERALDEP - General Dependencies (required both at compile and run time)
hp-check[42586]: info: :c. COMPILEDEP - Compile time Dependencies
hp-check[42586]: info: :d. [All are run-time checks]
hp-check[42586]: info: :PYEXT SCANCONF QUEUES PERMISSION
hp-check[42586]: info: :
hp-check[42586]: info: :Status Types:
hp-check[42586]: info: : OK
hp-check[42586]: info: : MISSING - Missing Dependency or Permission or Plug-in
hp-check[42586]: info: : INCOMPAT - Incompatible dependency-version or Plugin-version
hp-check[42586]: info: :
warning: [01mubuntu-20.04 version is not supported. Using ubuntu-19.10 versions dependencies to verify and install...[0m
hp-check[42586]: info: :
hp-check[42586]: info: :---------------
hp-check[42586]: info: 😐 SYSTEM INFO |
hp-check[42586]: info: :---------------
hp-check[42586]: info: :
hp-check[42586]: info: : Kernel: 5.4.0-65-generic #73-Ubuntu SMP Mon Jan 18 17:25:17 UTC 2021 GNU/Linux
Host: LenovoDesktop
Proc: 5.4.0-65-generic #73-Ubuntu SMP Mon Jan 18 17:25:17 UTC 2021 GNU/Linux
Distribution: ubuntu 20.04
hp-check[42586]: info: : Bitness: 64 bit

hp-check[42586]: info: :
hp-check[42586]: info: :-----------------------
hp-check[42586]: info: 😐 HPLIP CONFIGURATION |
hp-check[42586]: info: :-----------------------
hp-check[42586]: info: :
hp-check[42586]: info: :HPLIP-Version: HPLIP 3.21.2
hp-check[42586]: info: :HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro 20.04 version
hp-check[42586]: info: :
hp-check[42586]: info: :[01mCurrent contents of '/etc/hp/hplip.conf' file:[0m
hp-check[42586]: info: :# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.21.2

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip-3.21.2
html=/usr/share/doc/hplip-3.21.2
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=no
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.21.2
restricted-build=no
ui-toolkit=no
qt3=no
qt4=no
qt5=no
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=yes
class-driver=no

hp-check[42586]: info: :
hp-check[42586]: info: :[01mCurrent contents of '/var/lib/hp/hplip.state' file:[0m
hp-check[42586]: info: :Plugins are not installed. Could not access file: No such file or directory
hp-check[42586]: info: :
hp-check[42586]: info: :[01mCurrent contents of '~/.hplip/hplip.conf' file:[0m
hp-check[42586]: info: :[upgrade]
notify_upgrade = true
last_upgraded_time = 1613789128
pending_upgrade_time = 0

[last_used]
device_uri = hp:/usb/ENVY_Pro_6400_series?serial=TH0A73B1HB
printer_name = ENVY_Pro_6400

[installation]
date_time = 02/26/21 11:30:25
version = 3.21.2


hp-check[42586]: info: : <Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>
hp-check[42586]: info: :
hp-check[42586]: info: :-------------------------
hp-check[42586]: info: 😐 External Dependencies |
hp-check[42586]: info: :-------------------------
hp-check[42586]: info: :
hp-check[42586]: info: :[31;01m error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'[0m
hp-check[42586]: info: : gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.50 OK -
hp-check[42586]: info: : xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
hp-check[42586]: info: : scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.29 OK -
hp-check[42586]: info: : dbus DBus - Message bus system REQUIRED - 1.12.16 OK -
hp-check[42586]: info: : policykit PolicyKit - Administrative policy framework OPTIONAL - 0.105 OK -
hp-check[42586]: info: : network network -wget OPTIONAL - 1.20.3 OK -
hp-check[42586]: info: : avahi-utils avahi-utils OPTIONAL - 0.7 OK -
hp-check[42586]: info: :
hp-check[42586]: info: :------------------------
hp-check[42586]: info: 😐 General Dependencies |
hp-check[42586]: info: :------------------------
hp-check[42586]: info: :
hp-check[42586]: info: : libjpeg libjpeg - JPEG library REQUIRED - - OK -
hp-check[42586]: info: : cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - OK -
hp-check[42586]: info: : cups-image CUPS image - CUPS image development files REQUIRED - - OK -
hp-check[42586]: info: : libpthread libpthread - POSIX threads library REQUIRED - b'2.31' OK -
hp-check[42586]: info: : libusb libusb - USB library REQUIRED - 1.0 OK -
hp-check[42586]: info: : sane SANE - Scanning library REQUIRED - - OK -
hp-check[42586]: info: : sane-devel SANE - Scanning library development files REQUIRED - - OK -
hp-check[42586]: info: : libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.8 OK -
hp-check[42586]: info: : libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 OK -
hp-check[42586]: info: : python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.8.5 OK -
hp-check[42586]: info: : python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
hp-check[42586]: info: :[31;01m error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed'[0m
hp-check[42586]: info: :[31;01m error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'[0m
hp-check[42586]: info: : python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.16 OK -
hp-check[42586]: info: : python3-xml Python XML libraries REQUIRED - 2.2.9 OK -
hp-check[42586]: info: : python3-devel Python devel - Python development files REQUIRED 2.2 3.8.5 OK -
hp-check[42586]: info: : python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 7.0.0 OK -
hp-check[42586]: info: : python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.5.34 OK -
hp-check[42586]: info: :
hp-check[42586]: info: :--------------
hp-check[42586]: info: 😐 COMPILEDEP |
hp-check[42586]: info: :--------------
hp-check[42586]: info: :
hp-check[42586]: info: : libtool libtool - Library building support services REQUIRED - 2.4.6 OK -
hp-check[42586]: info: : gcc gcc - GNU Project C and C++ Compiler REQUIRED - 9.3.0 OK -
hp-check[42586]: info: : make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.2.1 OK -
hp-check[42586]: info: :
hp-check[42586]: info: :---------------------
hp-check[42586]: info: 😐 Python Extentions |
hp-check[42586]: info: :---------------------
hp-check[42586]: info: :
hp-check[42586]: info: : cupsext CUPS-Extension REQUIRED - 3.21.2 OK -
hp-check[42586]: info: : hpmudext IO-Extension REQUIRED - 3.21.2 OK -
hp-check[42586]: info: :
hp-check[42586]: info: :----------------------
hp-check[42586]: info: 😐 Scan Configuration |
hp-check[42586]: info: :----------------------
hp-check[42586]: info: :
hp-check[42586]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.21.2 OK 'hpaio found in /etc/sane.d/dll.conf'
hp-check[42586]: info: : scanext Scan-SANE-Extension REQUIRED - 3.21.2 OK -
hp-check[42586]: info: :
hp-check[42586]: info: :------------------------------
hp-check[42586]: info: 😐 DISCOVERED SCANNER DEVICES |
hp-check[42586]: info: :------------------------------
hp-check[42586]: info: :
hp-check[42586]: info: :No Scanner found.
hp-check[42586]: info: :
hp-check[42586]: info: :--------------------------
hp-check[42586]: info: 😐 DISCOVERED USB DEVICES |
hp-check[42586]: info: :--------------------------
hp-check[42586]: info: :
hp-check[42586]: info: :No devices found.
hp-check[42586]: info: :
hp-check[42586]: info: :---------------------------------
hp-check[42586]: info: 😐 INSTALLED CUPS PRINTER QUEUES |
hp-check[42586]: info: :---------------------------------
hp-check[42586]: info: :
hp-check[42586]: info: :
hp-check[42586]: info: :[01mENVY_Pro_6400[0m
hp-check[42586]: info: :[01m-------------[0m
hp-check[42586]: info: :Type: Printer
hp-check[42586]: info: :Device URI: hp:/usb/ENVY_Pro_6400_series?serial=TH0A73B1HB
hp-check[42586]: info: :PPD: /etc/cups/ppd/ENVY_Pro_6400.ppd
warning: Failed to read /etc/cups/ppd/ENVY_Pro_6400.ppd ppd file
hp-check[42586]: info: :PPD Description:
hp-check[42586]: info: :Printer: status: printer ENVY_Pro_6400 is idle. enabled since Sun 21 Feb 2021 08:22:25 PM PST
error: Communication status: Failed
hp-check[42586]: info: :
hp-check[42586]: info: :
hp-check[42586]: info: :--------------
hp-check[42586]: info: 😐 PERMISSION |
hp-check[42586]: info: :--------------
hp-check[42586]: info: :
hp-check[42586]: info: :
hp-check[42586]: info: :-----------
hp-check[42586]: info: 😐 SUMMARY |
hp-check[42586]: info: :-----------
hp-check[42586]: info: :
hp-check[42586]: info: :[01mMissing Required Dependencies[0m
hp-check[42586]: info: :[01m-----------------------------[0m
error: 'libcups2' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible
hp-check[42586]: info: :
hp-check[42586]: info: :[01mMissing Optional Dependencies[0m
hp-check[42586]: info: :[01m-----------------------------[0m
error: 'python3-dbus.mainloop.qt' package is missing/incompatible
hp-check[42586]: info: :
hp-check[42586]: info: :Total Errors: 4
hp-check[42586]: info: :Total Warnings: 0
hp-check[42586]: info: :
hp-check[42586]: info: :
hp-check[42586]: info: :Done.

 

 

2 REPLIES 2
Andr-1611
Level 15
Level 15
612 607 57 307
Message 2 of 3
Flag Post
HP Recommended

Hi @linux_is_best,

 

seen this yet? A pre-build package is available 

 

Just found this by accident. I am not a Unix/Ubuntu/Linux user.


Regards
Andreas


    
I'm not an employee of HP, I'm as volunteer here.
Requests via Private Messages (PM) cannot be answered.
0 Kudos
ShlomiL
Level 17
Level 17
31,176 30,890 5,327 12,408
Message 3 of 3
Flag Post
HP Recommended

Please follow the reply provided in the other thread @linux_is_best:

https://h30434.www3.hp.com/t5/Printer-Setup-Software-Drivers/Older-windows-drivers-for-HP-Envy-Pro-6...

 

This is a known behavior for a USB connection on Linux Mint 20.04, discussed in the release notes

 2. USB print and scan will not work on Vasari and Taccola on Ubuntu 20.04, please refer to link below
http://manpages.ubuntu.com/manpages/cosmic/man8/ippusbxd.8.html

Shlomi



Say thanks by clicking the Kudos thumb up in the post.
If my post resolve your problem please mark it as an Accepted Solution 🙂
0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation