cancel
Showing results for 
Search instead for 
Did you mean: 
jvv11
New member
4 3 0 0
Message 1 of 9
4,301
Flag Post

Solved!

Sprocket won't print, even after resetting.

HP Recommended

Hi, I have the Hp sprocket which I got last Christmas. It worked perfectly fine then, and still worked over the summer, however now I am trying to print and it is not working. I looked at other help comments, I tried resetting it, I made sure it was connected through bluetooth, and nothing is helping. I tried to update the firmware, but even that will not work. It just says "Sending firmware upgrade to sprocket printer" then it never finishes and nothing happens. When I try to print, it is connected and everything is fine, but as it says "sending to sprocket printer", nothing happens even though the white light flashes. Also, it will say its printing in the que section but t doesn;t print. I have paper in the sprocket, the que is empty, but nothing will print. Please help. 

0 Kudos
1 ACCEPTED SOLUTION

Accepted Solutions
Sender_XYZ
Level 3
35 27 2 8
Message 6 of 9
Flag Post
HP Recommended

Yes.  HP knows about the problem. Unfortunately, thre is no fix for this currently  and no estimation. 

 

Usually you may expect white LED to blink but the progress bar within HP Sprocket application won't move.  It seems like something is wrong during sending... This eventually leads to never ending firmware update (if you have firmware version < 1.1.5) and no print. However, this still doesn't explain why this happens on iOS 11.2. As Apple didn't change bluetooth API in that version. (But this kind of information (waht was wrong) probably won't be ever disclosed by HP)

 

Furthermore, until 6th of December Apple introduced issues as well within their XCode 9.2 (Development Env.) which caused inability to publish application updates to the App Store... (Fixed by now)  This could affect HP application update as well (if they already fixed the app).

 

 

View solution in original post

8 REPLIES 8
The_Fossette
HP Support Agent
HP Support Agent
29,155 29,140 1,953 2,593
Message 2 of 9
Flag Post
HP Recommended

Hi @jvv11,

 

Welcome to the HP Forums!

 

This is a wonderful place to converse with the community, get assistance and find tips.

 

I reviewed your post and understand that the printing is not printing.

 

I'll be glad to help you 🙂

 

In order that I may provide you with an accurate solution, I will need a few more details.

  • When was the last time the printer was working fine?
  • Are you getting any error when you print?

Meanwhile, follow the steps in the below article and check if it helps.

 

http://hp.care/2BH91Go

 

Let me know how it goes. Awaiting your reply!

 

To simply say thanks, please click the "Thumbs Up" button to give me a Kudos to appreciate my efforts to help. Give us some reinforcement by clicking “Accepted Solution” that'll help us and others see that we've got the answers!

 

Take care now and have a splendid week ahead.

 

Cheers 🙂

The_Fossette
I am an HP Employee

0 Kudos
jvv11
Author
New member
4 3 0 0
Message 3 of 9
Flag Post
HP Recommended

The last time that my Sprocket was working was August, and when I tried printing, I only got the error light about once or twice, however the other times that I tried the light would flicker white, meaning it's sending, but then it would just turn back to solid white. Also, I looked at the link that you sent with the suggestions, and none of those worked. I could not update firmware though, because every time that I tried, it would say that it was updating, but the downloading bar would not fill (it would stay in the same spot). Basically, I would come back after about an hour and the update hadn't progressed at all, so updating firmware is also not working. 

0 Kudos
Sender_XYZ
Level 3
35 27 2 8
Message 4 of 9
Flag Post
HP Recommended

Do you have an iPhone? If so do you have the latest iOS 11.2?

0 Kudos
jvv11
Author
New member
4 3 0 0
Message 5 of 9
Flag Post
HP Recommended

Yes, I just read that for some reason IOS 11.2 won't let sprocket properly function..?

0 Kudos
Sender_XYZ
Level 3
35 27 2 8
Message 6 of 9
Flag Post
HP Recommended

Yes.  HP knows about the problem. Unfortunately, thre is no fix for this currently  and no estimation. 

 

Usually you may expect white LED to blink but the progress bar within HP Sprocket application won't move.  It seems like something is wrong during sending... This eventually leads to never ending firmware update (if you have firmware version < 1.1.5) and no print. However, this still doesn't explain why this happens on iOS 11.2. As Apple didn't change bluetooth API in that version. (But this kind of information (waht was wrong) probably won't be ever disclosed by HP)

 

Furthermore, until 6th of December Apple introduced issues as well within their XCode 9.2 (Development Env.) which caused inability to publish application updates to the App Store... (Fixed by now)  This could affect HP application update as well (if they already fixed the app).

 

 

View solution in original post

jvv11
Author
New member
4 3 0 0
Message 7 of 9
Flag Post
HP Recommended

Is there an estimated time of when it will be fixed?

0 Kudos
Sender_XYZ
Level 3
35 27 2 8
Message 8 of 9
Flag Post
HP Recommended

All contact with HP support ends on such note as 'Information has been passed' or 'Information will be passed' without any estimation.

 

Application log output is not very verbose.

 

Normal printing produces the following 

Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::setStatus: status=Sending
Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::notifyStatusChanged: status=Sending size=1 timer=ON current=NO direct=YES
Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::setCurrentJob: job=id: ID0000006F 
name: (null) 
date: 2017-12-06 23:02:10 +0000 
pageRange: (null) 
numCopies: 1 
blackAndWhite: 0
extra: {
    Origin = Single;
    "app_type" = HP;
    "black_and_white_filter" = 0;
    "born_on_date" = "";
    card = "This column has been deprecated. Use the 'template_name' column instead.";
    copies = 1;
    "custom_data" =     {
        "hw_version" = "1.0.0";
        "tmd_version" = "0.0.5";
    };
    "fw_version" = "1.1.5";
    "model_number" = X7N08A;
    "number_pages_print" = 1;
    "off_ramp" = PrintWithNoUI;
    "paper_size" = "2 x 3";
    "paper_type" = "Photo Paper";
    "photo_source" = "Camera Roll";
    "printer_id" = "<REMOVED>";
    "printer_model" = "HP sprocket";
    "printer_name" = "HP sprocket (<REMOVED>)";
    "serial_number" = "<REMOVED>";
    "sprocket_embellishments" = "";
    "template_name" = "";
    "template_position" = "";
    "template_text" = "";
    "template_text_edited" = No;
    "user_id" = <REMOVED>
...    
Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::notifyStatusChanged: status=Sending size=1 timer=ON current=YES direct=YES
Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::didRefreshSprocketInfo: Sending job ID0000006F
Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Error | Unexpected protocol string: com.hp.protocol, defaulting to HP customer code
Dec  7 00:05:05 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | printReadyRequest: <1b2a4850 00000000 0230bf01 00000000 00000000 00000000 00000000 00000000 0000>
...
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::didSendPrintData: perecent=0 job=ID0000006F error=0
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: sprocket Debug | PRINT STATUS: SENDING JOB: 0%
Dec  7 00:05:06 <???> accessoryd[269] <Notice>: Data available from app for sessionID 6, sessionUUID 7F3C6970-31EB-4D24-A017-7546472F5DAD
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | 
...
StartOfSendAck: <1b2a4850 01000200 00000000 00000000 00000000 00000000 00000000 00000000 0000>
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug |    Payload Classification:  SprocketDataClassImage
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug |    Error: Ready
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::didSendPrintData: perecent=0 job=ID0000006F error=0
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: sprocket Debug | PRINT STATUS: SENDING JOB: 0%
Dec  7 00:05:06 <???> nsurlsessiond[108] <Notice>: Triggering periodic update to powerlog for client <private>
Dec  7 00:05:06 <???> trustd[128] <Notice>: could not disable pinning: not an internal release
Dec  7 00:05:06 <???> accessoryd[269] <Notice>: Data available from app for sessionID 6, sessionUUID 7F3C6970-31EB-4D24-A017-7546472F5DAD
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::didSendPrintData: perecent=1 job=ID0000006F error=0
Dec  7 00:05:06 <???> Sprocket[934] <Notice>: sprocket Debug | PRINT STATUS: SENDING JOB: 1%
Dec  7 00:05:08 <???> apsd(CommonUtilities)[85] <Notice>: Releasing power assertion {identifier: APSCourier(tcpStream:dataReceived:)}
Dec  7 00:05:09 <???> pasted[166] <Notice>: BundleID com.hp.sprocket from team 6HB5Y2QTA3 (pid 934) is requesting pasteboard fb_app_attribution
Dec  7 00:05:09 <???> pasted[166] <Notice>: ...requesting pasteboard fb_app_attribution completed. Error: (null)
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC Enabling TLS [21:0x1c036d5c0]
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TCP Conn Start [21:0x1c036d5c0]
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: Task <C08BC7DE-D28F-4456-9A38-EC0C773C8760>.<0> setting up Connection 21
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TLS Event [21:0x1c036d5c0]: 1, Pending(0)
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TLS Event [21:0x1c036d5c0]: 2, Pending(0)
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TLS Event [21:0x1c036d5c0]: 20, Pending(0)
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TCP Conn Connected [21:0x1c036d5c0]: Err(16)
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TCP Conn Event [21:0x1c036d5c0]: 1
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TCP Conn Event [21:0x1c036d5c0]: 8
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: TIC TLS Handshake Complete [21:0x1c036d5c0]
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: Task <C08BC7DE-D28F-4456-9A38-EC0C773C8760>.<0> now using Connection 21
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: Task <C08BC7DE-D28F-4456-9A38-EC0C773C8760>.<0> sent request, body D
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: Task <C08BC7DE-D28F-4456-9A38-EC0C773C8760>.<0> received response, status 200 content K
Dec  7 00:05:09 <???> Sprocket(CFNetwork)[934] <Notice>: Task <C08BC7DE-D28F-4456-9A38-EC0C773C8760>.<0> response ended

Dec  7 00:05:10 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: status=Sending
Dec  7 00:05:10 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: Sending job=ID0000006F
...
Dec  7 00:05:10 <???> assertiond[67] <Notice>: Updating PowerAssertion on Sprocket:934
..
Dec  7 00:05:10 <???> assertiond[67] <Notice>: Updating PowerAssertion on Sprocket:934
...
...
Dec  7 00:05:35 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: status=Sending
Dec  7 00:05:35 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: Sending job=ID0000006F
...
Dec 7 00:05:40 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: status=Sending
Dec 7 00:05:40 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: Sending job=ID0000006F
Dec 7 00:05:40 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::setStatus: status=Idle
Dec 7 00:05:40 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::notifyStatusChanged: status=Idle size=1 timer=ON current=YES direct=YES
... Dec 7 00:05:45 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: status=Idle Dec 7 00:05:45 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: Refreshing printer info Dec 7 00:05:45 <???> Sprocket[934] <Notice>: HPPhotoPrint Error | Unexpected protocol string: com.hp.protocol, defaulting to HP customer code Dec 7 00:05:45 <???> Sprocket[934] <Notice>: sprocket Debug | PGPreviewViewController::operation: DIRECT PRINT COMPLETE Dec 7 00:05:45 <???> Sprocket[934] <Notice>: sprocket Debug | PGPreviewViewController::operation: FINISH PRINTING

the log tells about how iPhone begins to send the print job. sets progress to 1%, then repeats 'status=Sending' several time and finishes with 'FINISH PRINTING'  after which we observer print loop within print queue. During sending state they also establish remote TCP/IP connection (removed from the log here) - this could be remote error reporting, as they do so within Android application...  No bluetooth related output is produced during send operation.

 

Print queue loop constantly produces the following (until queue items get deleted)

Dec  7 00:06:15 <???> Sprocket[934] <Notice>: HPPhotoPrint Error | Unexpected protocol string: com.hp.protocol, defaulting to HP customer code
Dec  7 00:06:15 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | accessoryInfoRequest: <1b2a4850 00000100 00000000 00000000 00000000 00000000 00000000 00000000 0000>
Dec  7 00:06:15 <???> Sprocket[934] <Notice>: sprocket Debug | PRINT STATUS: RESUMING PRINT QUEUE
Dec  7 00:06:15 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::didSendPrintData: perecent=1 job=ID0000006F error=0
Dec  7 00:06:15 <???> Sprocket[934] <Notice>: sprocket Debug | PRINT STATUS: RESUMING PRINT QUEUE
Dec  7 00:06:15 <???> accessoryd[269] <Notice>: Data available from app for sessionID 6, sessionUUID 7F3C6970-31EB-4D24-A017-7546472F5DAD
Dec  7 00:06:15 <???> atc(AirTrafficDevice)[38] <Notice>: <ATLegacyMessageLink: 0x1009e9fe0, wifi=0> ---> [Ping Request. id=42, Session=0, params=(null)]
Dec  7 00:06:20 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: status=Resuming
Dec  7 00:06:20 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | MPBTPrintManager::checkPrinterStatus: Refreshing printer info
Dec  7 00:06:20 <???> Sprocket[934] <Notice>: HPPhotoPrint Error | Unexpected protocol string: com.hp.protocol, defaulting to HP customer code
Dec  7 00:06:20 <???> Sprocket[934] <Notice>: HPPhotoPrint Debug | accessoryInfoRequest: <1b2a4850 00000100 00000000 00000000 00000000 00000000 00000000 00000000 0000>

This is everything what is possible to get from the logs... 

 

I hope HP works on the fix. Based upon HP Sprocket application updates history they release updates quite frequently. 

 

0 Kudos
Bob_Headrick
Level 16
Level 16
33,379 26,736 2,430 9,103
Message 9 of 9
Flag Post
HP Recommended

The fix for iOS 11.2 is now available, see the post here.


Bob Headrick,  HP Expert

I am not an employee of HP, I am a volunteer posting here on my own time.

If your problem is solved please click the "Accept as Solution" button 

If my answer was helpful please click the "Thumbs Up" to say "Thank You"

0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation