cancel
Showing results for 
Search instead for 
Did you mean: 
y2_
New member
1 0 0 0
Flag Post
HP Recommended
Pavilion 17 e040us
Microsoft Windows 10 (64-bit)

I’ve been having this issue for about half a day, in the morning my laptop was running fine on google chrome, but after updating attempting to update a game my laptop started acting up. I tried to load google but it would give me an error saying “This site can’t provide a secure connection” I ran Windows diagnostics which gave me the “This remote device or resource won’t accept the connection”  I’ve tried everything that I was able to find online to fix the problem, I’ve uninstalled and reinstalled google, restarted my laptop a couple of times, even did a factory reset and wiped all the files n such, but still the same issue appears. Microsoft Edge can load up any sites fine  it’s just google chrome, and I know it isn’t a WiFi issue for the most part considering my desktop can run google chrome without any of these issues. At this point I’m unsure of what I can do now. If anyone has answer please help. 

Who Me Too'd this topic
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation