cancel
Showing results for 
Search instead for 
Did you mean: 
Common problems for INSTANT INK, HP+ PLANS: INK AND TONER
We would like to share some of the most frequently asked questions about Instant Ink. Check out this link: HP INSTANT INK, HP+ PLANS: INK AND TONER. .
mrenda
New member
3 2 0 0
Message 1 of 23
3,889
Flag Post

Solved!

HPWSProAdapter not started in Jetadmin

HP Recommended
LaserJet MFP 521dn

I´m having trouble adding an MFP 521dn to Jetadmin 10.4 SR4. It throws a "Communication Error: HPWSProAdapter Service is not started" error. We have other HP printers added without problems, but this one insn´t working. I have tried this solution, but didn´t work: https://support.hp.com/hr-en/document/c04746266

Besides, it is running on a VMWare ESXi VM with a single network adapter, so the previous fix should not apply, but I tried anyway.

I also saw someone post about certificate encryption using MD5 instead of SHA, but I renewed the self-signed certificate, using SHA, and it didn´t work.

 

Any help would be greatly appreciated!

22 REPLIES 22
ePrint1492
Level 3
21 21 4 4
Message 2 of 23
Flag Post
HP Recommended

Hi,

I have the same problem with a few new installations of Web Jetadmin 10.4 SR4 with FP8, 64 bit SW (J6052-10583.exe) and Pro systems.

Is the M521dn the only Pro system in the Web Jetadmin that does not work or are there other models as well?

Is the HPWSProAdapter service running?

Which os is installed on the server?

 

Regards

0 Kudos
mrenda
Author
New member
3 2 0 0
Message 3 of 23
Flag Post
HP Recommended

Thanks for the reply!

I have other printers like an m533, a p4015 and an m4345, but neither of these are "Pro" models, and all work fine with Jetadmin. The server is running on a Windows 7 x64 VM, and the HPWSProAdapter Service is running. I tried restarting it but to no avail.

0 Kudos
ePrint1492
Level 3
21 21 4 4
Message 4 of 23
Flag Post
HP Recommended

Hi,

please deinstall the current version and try with HP Web Jetadmin 10.4 SR3 64 bit SW build 10.4.103287.

You can download the version via this link: https://ithaus.sharefile.eu/d-s92dd8e2fd5a47779

 

In my cases it worked with this version and I suspect the current Web Jetadmin version has a bug.

 

Regards

mrenda
Author
New member
3 2 0 0
Message 5 of 23
Flag Post
HP Recommended

Thanks, it worked! It´s too bad this printer model apparently does not support the per user utilization report, which would be great now that it is properly detected

0 Kudos
ePrint1492
Level 3
21 21 4 4
Message 6 of 23
Flag Post
HP Recommended

As long as you use an HP driver and all necessary ports are open it should work. Of course, the data collection must also be activated for this device.

 

But for such a report I recommend a solution such as SafeCom or Equitrac.

 

0 Kudos
ComputerKevin
New member
1 1 0 0
Message 7 of 23
Flag Post
HP Recommended

Hi,

i have an higher Version 10.4.104106 SR4 but i have the same issue. I don´t want to downgrade.

I have the problem with a M501dn Printer. All other devices works fine.

Is there a setting on the printer that must be enabled? In the Web Jetadmin it shows "Communication error: HPWSProAdapter-Servie" Service is not started. But all other devices works.

0 Kudos
michael2371
New member
1 1 0 1
Message 8 of 23
Flag Post
HP Recommended

because this problem is still a thing, does someone have a download link for the 10.4 SR3 Verison that is working?

 

Google did not help in my case.....

Olli2
Level 3
30 22 1 5
Message 9 of 23
Flag Post
HP Recommended

There seems to be no setting within the printer you can change this behavior. All our "M...professional"-Printers reacted like that using the newest WJA. So we go back to Version 10.4.103287 and it worked again.

 

0 Kudos
Chris-101
New member
1 1 0 0
Message 10 of 23
Flag Post
HP Recommended

I have the same problem, evaluating JedAdmin right now, planning to use it for our small fleet of PageWide Pros and Manageds (7 devices in total).

 

None of the Pagewides show up without the aforementioned error. I am running the latest version of Web JetAdmin 10.4 SR5.

Funnily enough the one non-HP printer/MFP we have (a Brother) can connect just fine. Also had access to an OfficeJet 3830. Connected it to our network for test purposes and ran the discovery. Tada: It works completely fine!

 

Does this bug with the Pagewides seriously still exist? I cannot believe it 😕

 

@HP anything you can recommend? This way the software (and to some extent your printers) are pretty useless....

0 Kudos
Tags (1)
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation