cancel
JetPac76 Tutor
Tutor
3 2 0 4
Message 1 of 47
3,216
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

HP Accelerator Shell
Microsoft Windows 10 (64-bit)

I have a 2017 13" Spectre x360 hooked up to the Omen Accelerator. The USB & Ethernet is very laggy on the Accelerator Shell's ports.

I cannot game online using the intended config. Ethernet is very laggy and my mouse and keyboard flicker quite a lot and suffer i/o delays. I have all the latest firmwares, drivers et al. I am using an external 4K display, connected via display port. Worth mentioning I have the GTX 1060 GPU and a 4TB drive in the Accelerator - they work fine.

The work-a-round on ethernet dissapears when I switch to wifi. I have just ordered a USB hub to hook directly up the Spectre x360. This work-around should also solve the USB lag. I have read about other eGPUs with USB ports having similar issues.

I should be able to use the features of the product as advertised in an issue free, non-workaround way. It's a shame I can't use the Omen's network accelerator software for example.

Any advice or ideas please?

46 REPLIES 46
JetPac76 Tutor
Tutor
3 2 0 4
Message 2 of 47
3,163
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

Bump.

The powered USB hub + TB3 Ethernet adapter cable is the workaround. Not as elegant as the advert though. I even tried different TB3 cables. Stock and a 2m active cable - same issue.

I half suspect the 4K display is saturating the TB3 controller and/or using GPU overclocking utils is causing the port lag. I was hopping some HP boffin (ie beyond level 1)  would reply here so I don't need invest any more time or money.

Certainly not working as advertised but I'm still happy.

0 Kudos
HP Support Agent
HP Support Agent
21,157 20,776 1,357 2,142
Message 3 of 47
3,163
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

Hi @JetPac76,

 

I have escalated your concern to HP’s Support Team in your region to have it reviewed for available options if any.

You should be contacted within 4 business days (Excluding Holidays & Weekends).

 

Response times may vary by region.

Please send a Private Message, if you aren’t contacted within 4-5 business days.

 

If you are unfamiliar with how the Forum's private message capability works, you can learn about that here.

Thank you for visiting the HP Support Forum.

 

Regards,

Jeet_Singh
I am an HP Employee

0 Kudos
atm10 Top Student
Top Student
6 6 0 0
Message 4 of 47
3,119
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

I think I'm having the same issue as you are.

 

Spectre 13 X360 2017 model

hooked up to a Omen Accelerator shell

MSI GTX 1070 Gaming X

A samsung EVO 850 SSD

 

ALL my devices connected to the USB ports on omen including keyboard/mouse and headsets experience stuttering. The headsets even disconnects/reconnect as a USB device.

 

Tried:

I have downloaded some monitoring software trying to isolate the issue and it does not seem to coincide with heavy graphics card usage (GPU usage sometimes are less than 20% when the stuttering happens).

I have 2 x 24in 1080p screen and I've tried to use only one to reduce display bandwith - doesn't seem to work.

Tried to use a different mouse the problem persists.

 

Same as you after putting everyting on to a USB hub directly connected to the X360's USB port the issue seems to be gone. So it's pretty obvious there's something wrong with the Omen Accelerator either software or hardware.

 

I haven't paid too much attention to the internet lag (the usb issue has made it impossible to play any online game anyway.)

 

Hope HP can find out the issue and issue a fix soon.

 

Steve

0 Kudos
atm10 Top Student
Top Student
6 6 0 0
Message 5 of 47
3,116
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

Hi there - not sure could you please help escalate my case as well. Thank you!

0 Kudos
JetPac76 Tutor
Tutor
3 2 0 4
Message 6 of 47
3,091
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

Still no resolution other than work-a-round described above. Omen is HP Inc's gaming brand. If the Accel doesn't work properly under full GPU load then we deserve to be told. 

Still happy - at list price with USB dock + TB main machine ethernet - its still delivers excellent value.

Come on Inc, please reply!

To recap x360 13" mid 2017 (TB*4) suffering Omen Accel port lag under full load.

0 Kudos
myhrmans Top Student
Top Student
9 5 0 0
Message 7 of 47
3,051
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

I have the same exact problem, mouse and keyboard is lagging while connected to the Omen Accelerator. Everything on the latest driver and software.

Computer: 
HP 1030 G2 x360.

Read online that this seems to be a problem with the bios on other Thunderbolt devices and was fixed for the older computers in BIOS 1.09A.. but I can only upgrade to 1.08A

0 Kudos
myhrmans Top Student
Top Student
9 5 0 0
Message 8 of 47
3,019
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

Any comment HP?

0 Kudos
JsteinIMT Student
Student
1 1 0 0
Message 9 of 47
2,995
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

I'm having the same problem, please let me know how to resolve!

 

Accelerator connected to a Spectre x360

All drivers/bios/firmware up to date

Mouse & keyboard connected to Accelerator USB ports, both constantly disconnecting/reconnecting to my computer.

0 Kudos
itsoverlywarm Honor Student
Honor Student
3 2 0 0
Message 10 of 47
2,892
Flag Post
HP Recommended

Omen by HP Accelerator Shell - USB & Ethernet lag

I am also experiencing this problem. i plan to call HP on monday when their help center reopens.
Both keyboard and mouse experience drop outs and lag when connected to the usb ports on the accelerator.
I am using a razer blade stealth and currently no GPU inside the accelerator, i was just testing the usb ports so i can confirm it is not an issue with load.
I would love a solution to this other than using a USB hub as that defeats the purpose of me buying the accelerator.

please HP fix this issue or offer me some form of refund as this is not a working product.

It is worth noting i have tried the USB ports with my friends 360Spectre connected and it experiences the same issues.

0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation